Character Set doesn't apply to mail subject in the list

VERIFIED DUPLICATE of bug 90584

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 90584
16 years ago
14 years ago

People

(Reporter: Timothy Ha, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061104

I am using Mozilla mail to receive Russian email messages. Mozilla Mail can set
default charset to Cyrillic Windows-1251 or Cyrillic KOI8 and many other
charsets. This would apply to mail subjects in the mailbox list immediately.

But, if a message is in KOI8 and default charset is WIndows-1251, then the
message in the preview pane is OK, but the subject is wrong in the email list.
So if would be better to apply charset conversion to the subject in the mail
list, too. If the message body is in KOI8, usually the header is KOI8, too. But
Mozilla thinks it should be the same as the chosen "default" charset.

Reproducible: Always
Steps to Reproduce:
1. OPen Mozilla Mail
2. Change default charset for the inbox
3. Get russian email with different charsets..

Comment 1

15 years ago
Timothy Ha: are you still experiencing this problem with more current builds 
(1.3 or 1.4) of Mozilla?  If so, could you attach a sample failing email to this 
bug?

Comment 2

15 years ago
I believe this is a duplicate report.  Timothy Ha, if you are still reading this 
and you disagree with the dupe, go ahead and reopen the bug.

*** This bug has been marked as a duplicate of 90584 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
v.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.