Text overlapping itself near end of line (in very specific conditions)

RESOLVED DUPLICATE of bug 148399

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 148399
16 years ago
16 years ago

People

(Reporter: Thomas Andrews, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061104

When my window is a specific size (I'll upload the screen shot - Mozilla should
have some way to "capture" its current display sizing setup to ease reproduction
in circumstances like this) and I visit mozilla.org's front page with Mozilla
1.1a, the text in the italic link:

    <a href="http://www.mozilla.org/mozorg.html"><i>Mozilla at a Glance</i></a>.

in the "Download Mozilla" section gets mangled, with "Mozilla" and "at a"
overlapping.

Obviously browser width is the dominant factor - it's clearly related to line
wrapping.  Basically, you want to resize the width until the line should wrap
between "Mozilla" and "at a glance."



Reproducible: Always
Steps to Reproduce:
1. Resize the page to exactly match my screenshot
2. Load page and check the "Mozilla at a Glance" text.
3. Resize several times to make sure text breaks properly
between "Mozilla" and "at a Glance" when it should.
(Reporter)

Comment 1

16 years ago
Created attachment 89685 [details]
Screen shot
(Reporter)

Comment 2

16 years ago
Created attachment 89686 [details]
Stand-alone HTML example

Comment 3

16 years ago
WFM, current CVS, Linux. Resolving as dup of bug 148399.
(Fix checked in on the trunk June 14th)

*** This bug has been marked as a duplicate of 148399 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.