When changing tabs in tabbed browser, site navigation bar is not updated

VERIFIED DUPLICATE of bug 102905

Status

defect
VERIFIED DUPLICATE of bug 102905
17 years ago
11 years ago

People

(Reporter: mozilla, Assigned: jag+mozilla)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1a+) Gecko/20020623
BuildID:    2002062308

When using the tabbed browser, the site navigation bar is not updated properly.
So, if the page you're viewing (see the link provided below as an example)
supports <link rel="prev"> and <link rel="next"> links, for example, the next
and previous buttons in the site navigation bar will be active.

Then, if you switch to another tab, the site navigation bar will not be updated,
and the next and previous buttons will still be active and point to the
locations set for the first tab.

Similarly, if I'm browsing in a tab without those <link> elements, the site
navigation bar won't be activated, which is correct, but then when I switch back
to the tab that has the page with the <link> elements on it, the site navigation
bar still won't be activated, which is incorrect.

Reproducible: Always
Steps to Reproduce:
1. Open two tabs - try A. http://www.keithdevens.com/weblog/?2002-06-20 (random
day from my weblog) and B. mozilla.org
2. Refresh tab A - the site navigation bar should be active
3. Switch to tab B, the site navigation bar will still be active, even though it
shouldn't be.
4. Now refresh tab B. Site navigation bar goes away, like it should.
5. Go back to tab A, and the site navigation bar doesn't show up as it should.

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 102905 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.