Show /whatsnew page on the beta channel with Trailhead release on June 4th

RESOLVED FIXED

Status

defect
P1
normal
RESOLVED FIXED
3 months ago
2 months ago

People

(Reporter: erenaud, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(firefox68 fixed, firefox69 fixed)

Details

(Whiteboard: [releng:q2:2019], )

Attachments

(3 attachments, 1 obsolete attachment)

The request is to show the Trailhead whatsnew page to beta users coming from any previous version to the next dot release for 4 releases (so through to the release on June 13th)

Trailhead is scheduled for June 4th, which looks to be at the 68.0b9 release. We'd like the page shown to users upgrading from any earlier releases.

Content:
The Websites team will re-purpose the content, verbatim, from the content to be shown at https://www.mozilla.org/en-US/firefox/67.0.5/whatsnew/

Locales:
It will be shown only to EN, DE and FR locales

Should devedition also get the page displayed?

Also, what URL should be used? As of Bug 1536665, beta will be displaying https://www.mozilla.org/%LOCALE%/67.0beta/whatsnew/, but that doesn't include the beta number.

See Also: → 1549891

Tom - we'd like to go with https://www.mozilla.org/%LOCALE%/68.0beta/whatsnew/

We're going to put it behind a switch and take it live on Tuesday June 4th, 6 a.m. , as Alex explained that doing so beforehand would show the Trailhead content to users updating today through then, prior to the actual 'launch'.

Flags: needinfo?(mozilla)
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/integration/autoland/rev/333800d40691
Add support for displaying WNP conditionally on build-id; r=nthomas
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED

Comment on attachment 9068438 [details]
Bug 1549889: Add support for displaying WNP conditionally on build-id; r?nthomas

Beta/Release Uplift Approval Request

  • User impact if declined: WNP for trailhead will not be setup for beta's by automation.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky):
  • String changes made/needed:
Flags: needinfo?(mozilla)
Attachment #9068438 - Flags: approval-mozilla-beta?
Attachment #9068439 - Flags: approval-mozilla-beta?

Comment on attachment 9068438 [details]
Bug 1549889: Add support for displaying WNP conditionally on build-id; r?nthomas

wnp setup for trailhead on beta/aurora. should go in 68.0b7

Attachment #9068438 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9068439 - Flags: approval-mozilla-beta?
Attachment #9068439 - Flags: approval-mozilla-beta+
Duplicate of this bug: 1549891

I've tested on Firefox 68 Beta 7 on "beta-cdntest" and "aurora-cdntest" channels and the Trailhead whatsnew page is correctly displayed for en-US, DE and FR locales.
For more information, see our test plan: https://docs.google.com/document/d/1LDOlEpLR2zvDCsJw2B_EG1frEZwOV69GTGXGReHpNhg/edit

Tested on Firefox 68 Beta 7 on "beta" and "aurora" channels and the Trailhead whatsnew page is correctly displayed for en-US, DE and FR locales.
For more information, see our test plan: https://docs.google.com/document/d/1LDOlEpLR2zvDCsJw2B_EG1frEZwOV69GTGXGReHpNhg/edit

The request was to enable this for 4 beta builds.

Backed out changeset 692af65f1c26 (bug 1549889)
Backed out changeset 5527500a9cf7 (bug 1549889)

Attachment #9073311 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.