Closed Bug 1549926 Opened 2 years ago Closed 1 year ago

WasmTextToBinary: Accept the `offset` syntax for data and elem segments

Categories

(Core :: Javascript: WebAssembly, enhancement, P3)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1612534

People

(Reporter: lth, Unassigned, Mentored)

References

Details

(Keywords: good-first-bug)

The official wat syntax canonically uses (offset <const-expr>) to specify the offset for active segments, but we do not recognize this.

More information here, for starters: https://bugzilla.mozilla.org/show_bug.cgi?id=1545761#c4

Also note the interaction of this with the passive specifier, which may go away: bug 1546074.

Depends on: 1612534
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1612534
You need to log in before you can comment on or make changes to this bug.