Closed Bug 1550030 Opened 6 months ago Closed 26 days ago

Implement DOM mutation breakpoint UX for inspector markup view

Categories

(DevTools :: Debugger, enhancement, P3)

enhancement

Tracking

(firefox71 fixed)

RESOLVED FIXED
Firefox 71
Tracking Status
firefox71 --- fixed

People

(Reporter: Honza, Assigned: gl)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [debugger-reserve])

Attachments

(2 files)

When adding a DOM Breakpoint in the Inspector, I want to see an indicator in the markup view, so that I have visual confirmation and an easy way to remove it.

Honza

Type: defect → enhancement
Priority: -- → P3
Summary: Visual breakpoint indicator in Inspector’s markup → Implement the element inspector tree UI for DOM mutation breakpoints
Summary: Implement the element inspector tree UI for DOM mutation breakpoints → Implement DOM mutation breakpoint UX for inspector markup view
Duplicate of this bug: 1550026
Whiteboard: [debugger-mvp]
Assignee: nobody → gl
Status: NEW → ASSIGNED

Mockup link (in progress - feedback wanted)

Depends on: 1548703

This might rely on new server APIs introduced in Bug 1550835. Please test backward compatibility when working on this or ping me for review. Thanks!

Depends on: 1550835

This implements the context menu items for the DOM mutation breakpoint.
In addition, there were some server changes to:

  • Update the mutationBreakpoints form for the NodeActor
  • Expose the mutationBreakpoints form
  • Moved the setMutationBreakpoints method from the Node spec to Walker spec
    since the Node spec only consisted of getter methods. It made more sense
    that the setter went into the Walker spec to be more consistent with how
    the Walker and Node spec have been arranged.

Unit tests will be followed up in Part 2 immediately.

Keywords: leave-open
Pushed by gabriel.luong@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1fb51bb3f412
Part 1: Implement the DOM mutation breakpoint context menu items in the markup view. r=loganfsmyth,jdescottes
Blocks: dbg-70
No longer blocks: dbg-70
Whiteboard: [debugger-mvp]

Can this be closed with Gabriel's patch?

(In reply to David Walsh :davidwalsh from comment #7)

Can this be closed with Gabriel's patch?

Yea, I left it open so I could add some unit tests for it, but that can always go in a new bug.

Ah, I actually hadn't finalized the gutter icon design work yet - is that not what this bug is about?

Flags: needinfo?(gl)

(In reply to Victoria Wang [:victoria] from comment #9)

Ah, I actually hadn't finalized the gutter icon design work yet - is that not what this bug is about?

Ah yes, I guess we should probably rename and close this bug and spawn new bugs for the new work since we ended up using this bug for implementing the context menu.

Flags: needinfo?(gl)
Blocks: dbg-dom-bps
No longer blocks: dbg-dom-bps-m1
Blocks: dbg-71
Whiteboard: [debugger-reserve]
Pushed by dwalsh@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/284c86226071
Show breakpoint icon in inspector for DOM Mutation Breakpoints r=gl
Regressions: 1583034

Looks like all work related to this landed.

Status: ASSIGNED → RESOLVED
Closed: 26 days ago
Keywords: leave-open
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
You need to log in before you can comment on or make changes to this bug.