Closed Bug 1550389 Opened 1 year ago Closed 1 year ago

--enable-warnings-as-errors fails due to -D unused-mut with Rust 1.36

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: jbeich, Assigned: emilio)

References

(Regression)

Details

$ rustc -vV
rustc 1.36.0-nightly
binary: rustc
commit-hash: 3f5152e200c0c02dfe0f79367948c98053d35855
commit-date: 2019-05-08
host: x86_64-unknown-freebsd
release: 1.36.0-nightly
LLVM version: 8.0

$ echo "ac_add_options --enable-warnings-as-errors" >>.mozconfig
$ ./mach build
[...]
error: variable does not need to be mutable
--> servo/components/style/properties/declaration_block.rs:1385:10
|
1385 | for (mut error, slice, property) in errors.drain() {
| ----^^^^^
| |
| help: remove this mut
|
= note: -D unused-mut implied by -D warnings
error: aborting due to previous error
error: Could not compile style.

If only my local warnings weren't busted because of https://github.com/rust-lang/rust/issues/60050...

Assignee: nobody → emilio

(Thanks for the report :))

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.