Closed Bug 1551037 Opened 1 year ago Closed 1 year ago

[Automated review] Claimed number of coverity defects doesn't match number actually reported

Categories

(Firefox Build System :: Source Code Analysis, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1542163

People

(Reporter: jfkthame, Assigned: andi)

References

(Blocks 1 open bug)

Details

See for example: https://phabricator.services.mozilla.com/D30788#905365

This comment says:

Code analysis found 7 defects in this patch:
• 7 defects found by Coverity

but then only two issues are actually reported.

(The reported defects are not related to the current patch, they just happen to be in a file that was touched, but that's a separate issue.)

It's a bit confusing to see the claim that there are 7 defects, but then only be told what 2 of them are...

Could you please take care of that? Thanks

Flags: needinfo?(bpostelnicu)
Priority: -- → P1

@Sylvestre, yes, this one we should close it.

Flags: needinfo?(bpostelnicu)
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1551098

I'm not sure this is exactly a dupe of bug 1551098. That bug is about coverity giving reports for stuff that the patch didn't touch. (Which is also the case here, but it's not the specific point I was reporting.)

The issue here is the internal discrepancy within the report:

Code analysis found 7 defects in this patch:
7 defects found by Coverity
If you see a problem in this automated review, please report it here.

intl/lwbrk/LineBreaker.cpp  
650 "Init" dereferences null "this->mUniText".
727 "GetCodeUnitAt" dereferences null "this->mText".

where the number of issues actually listed (2) doesn't match the "7 defects" in the heading.

Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Assignee: nobody → bpostelnicu

You have a point here and I will post a patch.

I'm still going to close this since the fix will be part of bug 1542163, the problem here is that Coverity discovers some issues that are not in files that are part of the patch, but are in files that are part of the same compilation unit. The fix will filter out these files just like we don with clang-tidy analysis where we match the issue to be part of the patch.

Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1542163
No longer regressed by: coverity-analysis
You need to log in before you can comment on or make changes to this bug.