Closed Bug 1551065 Opened 6 months ago Closed 6 months ago

Quora freezes on the latest nightly (2019-05-11)

Categories

(Core :: Layout, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 + fixed

People

(Reporter: jjjudas, Assigned: emilio)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

Go to www.quora.com

Actual results:

No links can be clicked, when you leave the tab and return to it, it is displaying the loading animation instead of content.

Expected results:

The website should be readable as normal.

I have tried to do the same with the same account in a different browser (MS edge) to rule out a problem in quora, and it works normally there

I have also tested it on the regular firefox (67.0b19) and it works there so it really has to be in the latest nightly. I am also pretty sure it worked normally in yesterday's nightly.

Steps to reproduce:

  1. Go to www.quora.com
  2. Log-in

Actual Results:
The page is forever loading
No links can be clicked

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=d94d1e2c6f436c33725709bf93c99f6930fd8e99&tochange=c2250a23fd66e3c812cb023c2d12f6f5e8d5a2f2

Regressed by:
c2250a23fd66e3c812cb023c2d12f6f5e8d5a2f2 Cameron McCormack — Bug 866102 - Implement -webkit-line-clamp. r=mats,emilio,dholbert

Cameron,
Your patch seems to cause the regression. Can you look into this?

Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → CSS Parsing and Computation
Ever confirmed: true
Flags: needinfo?(cam)
Keywords: regression
Product: Firefox → Core
Regressed by: webkit-line-clamp

[Tracking Requested - why for this release]: Pretty bad regression in a popular site.

Component: CSS Parsing and Computation → Layout
Priority: -- → P1
See Also: → 1551087
Assignee: nobody → emilio
Flags: needinfo?(cam)

That being said, this code is clearly not getting hit, are we 100% sure that
this is interoperable with what WebKit / Blink do?

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/430b79a1444f
Properly discard empty lines for -webkit-line-clamp. r=heycam
Duplicate of this bug: 1551182

(In reply to jjjudas from comment #0)

I have tried to do the same with the same account in a different browser (MS edge) to rule out a problem in quora, and it works normally there

It works normally AT THE SAME TIME ON THE SAME COMPUTER in the stable. (But due to the Windows change, the stable no longer does sound in YouTube - so sound or quora, not both).

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/16881 for changes under testing/web-platform/tests
Upstream PR merged
You need to log in before you can comment on or make changes to this bug.