All inspector sub-suites fail when run on a clean build `head.js import threw an exception`

RESOLVED FIXED in Firefox 68

Status

defect
RESOLVED FIXED
Last month
Last month

People

(Reporter: jdescottes, Assigned: jdescottes)

Tracking

(Regression)

unspecified
Firefox 68

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(1 attachment)

STRs:

  • ./mach clobber
  • ./mach build
  • ./mach test devtools/client/inspector/computed/test/browser_computed_search-filter_context-menu.js

Will fail with

Unexpected Results
------------------
devtools/client/inspector/computed/test/browser_computed_search-filter_context-menu.js
  FAIL head.js import threw an exception - Error opening input stream (invalid filename?): chrome://mochitests/content/browser/devtools/client/debugger/test/mochitest/helpers/context.js

Regression from Bug 1543821. This bug started importing a debugger script in inspector/test/head.js. However this head.js is reused in a lot of other subsuites of the inspector, so devtools/client/debugger/test/mochitest/helpers/context.js should be whitelisted in every browser.ini that imports inspector/test/head.js.

Importing scripts in shared head files is hard to maintain because all it forces all browser ini that use the shared file to whitelist all its imports.
The debugger context helper is almost unused in the inspector, so it would be easier to just import it in the few tests that require it.
Also removed the whitelist entry in rules' browser.ini, no test in this suite used it.

Comment 2

Last month
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/87e01787d465
Move import of mochitest/helpers/context.js to test instead of head.js r=pbro

Comment 3

Last month
bugherder
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Assignee: nobody → jdescottes
You need to log in before you can comment on or make changes to this bug.