[WIN] - Acer - FFX 62+ not displaying languagePack in about:addons language section

VERIFIED FIXED in Firefox 67

Status

()

defect
P1
major
VERIFIED FIXED
Last month
19 days ago

People

(Reporter: cfogel, Assigned: mkaply)

Tracking

({regression})

Trunk
Firefox 68
All
Windows
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 wontfix, firefox67blocking verified, firefox68 fixed)

Details

Attachments

(3 attachments, 1 obsolete attachment)

Posted image Screenshot_26.png

Affected versions

  • 67.0

Affected platforms

  • Windows 10, Windows 8.1

Steps to reproduce

  1. Install a Firefox (62+ version)- set up for Acer distribution;
  2. Set up the language pack as per instructions in the document bellow;
  3. Perform update;
  4. Access about:addons

*see this link for additional details;

Expected result

  • New section displayed under Plugins;

Actual result

  • The Languages section is not displayed;
  • After the restart, warning that the version is not compatible is displayed;

Regression range

  • issues started to reproduce with updates from Firefox 62;

Additional notes

  • attached screenshot with console log, xpi file renamed;
  • trying to redo the setup with versions prior to this, ex 58.0 does not exhibit this issue;
Posted image Screenshot_27.png

Hello! Opening Firefox 65.0 on the first run after following the steps from comment 0, the following messages (see screenshot) are displayed in the browser console:
1557823848286 addons.xpi-utils WARN Add-on langpack-tr@firefox.mozilla.org is not correctly signed.
1557823848292 addons.xpi-utils WARN addMetadata: Add-on langpack-tr@firefox.mozilla.org is invalid: Error: Extension langpack-tr@firefox.mozilla.org is not correctly signed(resource://gre/modules/addons/XPIDatabase.jsm:2343:17) JS Stack trace: addmetadata@xpidatabase.jsm:2343:17
processfilechanges@xpidatabase.jsm:2686:21
checkforchanges@xpiprovider.jsm:2581:34
startup@xpiprovider.jsm:2159:25
callprovider@addonmanager.jsm:203:12
_startprovider@addonmanager.jsm:652:5
startup@addonmanager.jsm:805:9
startup@addonmanager.jsm:2775:5
observe@addonmanager.js:66:9

Mike, could you investigate and triage wrt our upcoming 67 release next week? Thanks

Flags: needinfo?(mozilla)

I installed Firefox 66.0.5 "de" and "en-US" x64 builds (- set up for Acer distribution) -> I set up the language pack as per instructions in the document from Description -> Perform update (Firefox is updated to 67.0) and then access about:addons -> The Languages section is displayed.
It seems that for builds updated from Firefox 66.0.5, Languages section is correctly displayed.

I've tested on Windows 7 x64 and Windows 10 x64.

Assignee

Comment 4

Last month

Summary of what is happening:

Firefox 62 tries to install the addon from the distribution directory, but it fails because of the signature problem.
Even though the install failed, we set the pref:

extensions.installedDistroAddon.langpack-de@firefox.mozilla.org

to true

Because this pref is set to true, we will never try to install the distribution langpacks again.

Flags: needinfo?(mozilla)
Assignee

Comment 5

Last month

This bug should block 67. We need to do a one time reset of distro addon prefs.

Assignee

Comment 6

Last month

Also we need to fix the bug here:

https://searchfox.org/mozilla-central/source/toolkit/mozapps/extensions/internal/XPIInstall.jsm#3340

We should not set this pref if the install didn't succeed.

Assignee

Updated

Last month
Attachment #9064941 - Attachment is obsolete: true
Assignee

Comment 8

Last month

[Tracking Requested - why for this release]: This is as major blocker for Acer preloads.

They are already in the store, so we have to figure out how to fix this in an update.

Priority: -- → P1
Assignee

Updated

Last month
Status: NEW → ASSIGNED

Mike, this patch is r+, what is preventing the landing and uplift request?

Flags: needinfo?(mozilla)

Worth asking if this is needed in ESR repo or not.

Assignee

Comment 12

Last month

Comment on attachment 9065409 [details]
Bug 1551455 - Reinstall distribution language packs.

Beta/Release Uplift Approval Request

  • User impact if declined: Acer preloads lose their language packs.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Steps are in bug, QA is familiar
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Only affects this very specific case (locales that are installed via distribution)
  • String changes made/needed:
Flags: needinfo?(mozilla)
Attachment #9065409 - Flags: approval-mozilla-beta?
Assignee

Updated

Last month
Flags: qe-verify+
Assignee

Comment 13

Last month

This is not needed on ESR.

Comment on attachment 9065409 [details]
Bug 1551455 - Reinstall distribution language packs.

Release blocker, uplift approved for RC2.

Attachment #9065409 - Flags: approval-mozilla-beta? → approval-mozilla-release+

Comment 16

Last month
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/296ca33d9a0e
Reinstall distribution language packs. r=kmag
Reporter

Comment 17

Last month

Fix verified with 67.0 - build 2.
For a detailed report, check the test run in this link.

Status: ASSIGNED → RESOLVED
Closed: Last month
Flags: qe-verify+
Resolution: --- → FIXED
Reporter

Comment 18

Last month

Updating status for bug.

Status: RESOLVED → VERIFIED
Target Milestone: --- → Firefox 68
You need to log in before you can comment on or make changes to this bug.