Closed Bug 1551867 Opened 6 months ago Closed 6 months ago

Permafailing browser/components/enterprisepolicies/tests/xpcshell/test_extensionsettings.js | xpcshell return code: 0

Categories

(Firefox :: Enterprise Policies, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox67.0.1 --- unaffected
firefox68 + verified

People

(Reporter: nataliaCs, Assigned: mkaply)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:
Central as Beta:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=397d66eae5f1ffff6217aa79ae052393e7106ad1&searchStr=xpcshell&group_state=expanded&selectedJob=246572189

failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=246572189&repo=try&lineNumber=5396

11:48:28 INFO - TEST-START | browser/components/enterprisepolicies/tests/xpcshell/test_extensionsettings.js
11:48:28 WARNING - TEST-UNEXPECTED-FAIL | browser/components/enterprisepolicies/tests/xpcshell/test_extensionsettings.js | xpcshell return code: 0
11:48:28 INFO - TEST-INFO took 280ms
11:48:28 INFO - >>>>>>>
11:48:28 INFO - PID 10136 | JavaScript strict warning: jar:file:///Z:/task_1557917522/build/application/firefox/omni.ja!/components/EnterprisePolicies.js, line 513: ReferenceError: reference to undefined property "name"
11:48:28 INFO - "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "ReferenceError: reference to undefined property "name"" {file: "jar:file:///Z:/task_1557917522/build/application/firefox/omni.ja!/components/EnterprisePolicies.js" line: 513}]"

:mkaply could you please take a look? Thank you.

Flags: needinfo?(mozilla)

i'm looking into this. It's really strange because it's the same error as the other bug (which was fixed) and it's only happening on Windows opt?

Flags: needinfo?(mozilla)

How do I download the build artifacts for this build?

  1. Click on the build at https://treeherder.mozilla.org/#/jobs?repo=try&revision=397d66eae5f1ffff6217aa79ae052393e7106ad1&group_state=expanded&searchStr=build
  2. At the bottom, click on "Job Details".
  3. Download.
    If you want to build locally and use the artifacts from that build, https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Build_Instructions/Artifact_builds#Pulling_artifacts_from_a_try_build , using https://hg.mozilla.org/mozilla-central/rev/76bbedc1ec1ae367906390c01a8ca008d7944cac as local revision and running ./mach try release -v 68.0b1 --tasks release-sim --migration central-to-beta --no-push && hg commit -m "Early beta config" are necessary.
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/243251620b8e
Move appinfo init to head to avoid timing when initing enterprise policies. r=rstrong
Assignee: nobody → mozilla
Status: NEW → ASSIGNED
Priority: -- → P1
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
You need to log in before you can comment on or make changes to this bug.