[File a new bug if this happens again] Intermittent browser_doorhanger_sp_patch_partialApplyFailure.js | The PanelUI.notificationPanel.state should equal open - Got closed, expected open

RESOLVED FIXED in Firefox 68

Status

()

defect
P5
normal
RESOLVED FIXED
Last month
10 days ago

People

(Reporter: intermittent-bug-filer, Assigned: rstrong)

Tracking

({intermittent-failure, regression})

unspecified
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox67.0.5 unaffected, firefox68 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

Last month
treeherder

Filed by: aciure [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=246781176&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/Hdn9XQrcQcmYrT_Xy75x3Q/runs/0/artifacts/public/logs/live_backing.log


[task 2019-05-16T11:12:09.486Z] 11:12:09 INFO - TEST-START | toolkit/mozapps/update/tests/browser/browser_doorhanger_sp_patch_partialApplyFailure.js
[task 2019-05-16T11:12:29.856Z] 11:12:29 INFO - TEST-INFO | started process screentopng
[task 2019-05-16T11:12:30.276Z] 11:12:30 INFO - TEST-INFO | screentopng: exit 0
[task 2019-05-16T11:12:30.276Z] 11:12:30 INFO - Buffered messages logged at 11:12:09
[task 2019-05-16T11:12:30.276Z] 11:12:30 INFO - Entering test bound setupTestCommon
[task 2019-05-16T11:12:30.278Z] 11:12:30 INFO - Leaving test bound setupTestCommon
[task 2019-05-16T11:12:30.279Z] 11:12:30 INFO - Entering test bound doorhanger_sp_patch_partialApplyFailure
[task 2019-05-16T11:12:30.282Z] 11:12:30 INFO - Buffered messages logged at 11:12:29
[task 2019-05-16T11:12:30.283Z] 11:12:30 INFO - 11:12:29:843 | TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js | [runDoorhangerUpdateTest/processDoorhangerStep/< : 542] Waiting on PanelUI.notificationPanel.state to equal open - timed out after 200 tries.
[task 2019-05-16T11:12:30.284Z] 11:12:30 INFO - Buffered messages finished
[task 2019-05-16T11:12:30.285Z] 11:12:30 INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/update/tests/browser/browser_doorhanger_sp_patch_partialApplyFailure.js | The PanelUI.notificationPanel.state should equal open - Got closed, expected open
[task 2019-05-16T11:12:30.287Z] 11:12:30 INFO - Stack trace:
[task 2019-05-16T11:12:30.288Z] 11:12:30 INFO - chrome://mochikit/content/browser-test.js:test_is:1325
[task 2019-05-16T11:12:30.289Z] 11:12:30 INFO - chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js:runDoorhangerUpdateTest/processDoorhangerStep/<:544
[task 2019-05-16T11:12:30.289Z] 11:12:30 INFO - chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js:processDoorhangerStep:574
[task 2019-05-16T11:12:30.289Z] 11:12:30 INFO - chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js:runDoorhangerUpdateTest/<:613
[task 2019-05-16T11:12:30.290Z] 11:12:30 INFO - chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js:runDoorhangerUpdateTest:615
[task 2019-05-16T11:12:30.291Z] 11:12:30 INFO - chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/browser_doorhanger_sp_patch_partialApplyFailure.js:doorhanger_sp_patch_partialApplyFailure:16
[task 2019-05-16T11:12:30.293Z] 11:12:30 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1116
[task 2019-05-16T11:12:30.293Z] 11:12:30 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1144
[task 2019-05-16T11:12:30.294Z] 11:12:30 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1005
[task 2019-05-16T11:12:30.295Z] 11:12:30 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
[task 2019-05-16T11:12:30.296Z] 11:12:30 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-05-16T11:12:30.297Z] 11:12:30 INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/update/tests/browser/browser_doorhanger_sp_patch_partialApplyFailure.js | Uncaught exception - at chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js:546 - TypeError: AppMenuNotifications.activeNotification is null
[task 2019-05-16T11:12:30.298Z] 11:12:30 INFO - Stack trace:
[task 2019-05-16T11:12:30.298Z] 11:12:30 INFO - runDoorhangerUpdateTest/processDoorhangerStep/<@chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js:546:35
[task 2019-05-16T11:12:30.299Z] 11:12:30 INFO - asyncprocessDoorhangerStep@chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js:574:7
[task 2019-05-16T11:12:30.299Z] 11:12:30 INFO - runDoorhangerUpdateTest/<@chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js:613:13
[task 2019-05-16T11:12:30.300Z] 11:12:30 INFO - async
runDoorhangerUpdateTest@chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/head.js:615:5
[task 2019-05-16T11:12:30.301Z] 11:12:30 INFO - doorhanger_sp_patch_partialApplyFailure@chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/browser_doorhanger_sp_patch_partialApplyFailure.js:16:9
[task 2019-05-16T11:12:30.301Z] 11:12:30 INFO - Tester_execTest/<@chrome://mochikit/content/browser-test.js:1116:34
[task 2019-05-16T11:12:30.302Z] 11:12:30 INFO - async*Tester_execTest@chrome://mochikit/content/browser-test.js:1144:12
[task 2019-05-16T11:12:30.302Z] 11:12:30 INFO - nextTest/<@chrome://mochikit/content/browser-test.js:1005:14
[task 2019-05-16T11:12:30.302Z] 11:12:30 INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:803:59
[task 2019-05-16T11:12:30.305Z] 11:12:30 INFO - Leaving test bound doorhanger_sp_patch_partialApplyFailure
[task 2019-05-16T11:12:30.306Z] 11:12:30 INFO - GECKO(12911) | MEMORY STAT | vsize 3113MB | residentFast 344MB | heapAllocated 109MB
[task 2019-05-16T11:12:30.307Z] 11:12:30 INFO - TEST-OK | toolkit/mozapps/update/tests/browser/browser_doorhanger_sp_patch_partialApplyFailure.js | took 20399ms
[task 2019-05-16T11:12:30.307Z] 11:12:30 INFO - checking window state

Makes the startup processing doorhanger tests immediately reload the update manager after writing the active-update.xml so there isn't a race
Reverts the doorhanger tests to waiting for the popupshown even since that wasn't failing previously
Sets the app.update.badgeWaitTime and app.update.promptWaitTime prefs so non-doorhanger tests don't display the doorhanger as often
Changes browser_doorhanger_bc_downloadOptIn_staging.js to use the app.update.promptWaitTime so it tests that the pref works
Added a call to UpdateListener.reset() to reset UpdateListener during the common test setup
Added a call to AppMenuNotifications.removeNotification(/.*/) to remove doorhangers when a test finishes

Comment 2

Last month
Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f3b9043b4ab1
fix race condition in doorhanger startup processing tests. r=bytesized

Comment 3

Last month
bugherder
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Summary: Intermittent toolkit/mozapps/update/tests/browser/browser_doorhanger_sp_patch_partialApplyFailure.js | The PanelUI.notificationPanel.state should equal open - Got closed, expected open → [File a new bug if this happens again] Intermittent browser_doorhanger_sp_patch_partialApplyFailure.js | The PanelUI.notificationPanel.state should equal open - Got closed, expected open
Assignee: nobody → robert.strong.bugs
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.