Closed Bug 1552275 Opened 7 months ago Closed 7 months ago

Copy link address from inspector doesn't work

Categories

(DevTools :: Inspector, defect, P1)

defect

Tracking

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 verified, firefox68 verified, firefox69 verified)

VERIFIED FIXED
Firefox 69
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- verified
firefox68 --- verified
firefox69 --- verified

People

(Reporter: calixte, Assigned: rcaliman)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [qa-triaged])

Attachments

(1 file)

STR:

In using mozregression, I get:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9c0bb955c19d90c1886b9af34d744eff5f110e52&tochange=e92ff56d2be21676b447c6fbb87b4c4479539bc9

Flags: needinfo?(gl)
Has Regression Range: --- → yes
Has STR: --- → yes

Fix-optional for 67, we might take a safe patch as a ridealong in a dot release.

Assignee: nobody → rcaliman
Status: NEW → ASSIGNED
Priority: -- → P1
  • Fixes the references to the correct event handler & InspectorFront after a previous mass refactoring in Bug 1529364.
  • Augments a test to ensure the clipboard content is correct executing the context menu action to copy a link.

Thanks for discovering this :calixte!

I fixed the issue (a slight renaming mishap) and augmented one of our tests to check the clipboard.

I consider it a pretty safe patch. Once reviewed, we should aim to uplift this as soon as possible to 67 and 68. This is pretty important. "Copy Link Address" didn't work on any node type, not just <audio>.

Flags: needinfo?(gl)
Pushed by rcaliman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d4c346b146a1
Fix Copy Link context menu in DevTools Inspector markup view. r=gl
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

Please request beta uplift when you get a chance. Thanks!

Flags: qe-verify+
Flags: in-testsuite+
Flags: needinfo?(rcaliman)

Comment on attachment 9066009 [details]
Bug 1552275 - Fix Copy Link context menu in DevTools Inspector markup view. r=gl

Beta/Release Uplift Approval Request

  • User impact if declined: Users are unable to use the context menu in the DevTools Inspector markup view to copy the href/src from <a>, <img>, <script>, <link>, <video> and <audio> tags.
    On click on the Copy Link Address option from the context menu invoked on the href/src attribute of a node, nothing is copied to the clipboard. Regressed by a change in bug 1529364.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Steps to verify:
  • Navigate to any website
  • Open DevTools Inspector and inspect any <a> or <img> tag in the markup view
  • Right click on the href or src attribute of that tag
  • Pick the "Copy Link Address" option from the context menu
  • Paste the clipboard content into a file

Expected:
On paste, the clipboard content should hold the complete absolute URL (including domain) of the copied href or src attribute

  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The patch to fix the regression re-instates preexisting functionality that was accidentally disconnected. The patch fixes a typo in a method name and a mistaken reference. It updates a test to check that the behavior works as expected. No new user-facing functionality added.
  • String changes made/needed:
Flags: needinfo?(rcaliman)
Attachment #9066009 - Flags: approval-mozilla-release?
Attachment #9066009 - Flags: approval-mozilla-beta?

Has the fix been verified in Nightly?: Yes

I left that bank in the form, but it still showed up as a "Yes".
Clarification: I did test in Nightly and the fix works as expected, but still needs a formal check by QA as requested with the qe-verify+ flag by :jcristau

Whiteboard: [qa-triaged]

Verified as fixed on Firefox Nightly 69.0a1 (2019-05-23) on Windows 10 x 64, Mac OS X 10.14 and on Ubuntu 18.04 x64.

Comment on attachment 9066009 [details]
Bug 1552275 - Fix Copy Link context menu in DevTools Inspector markup view. r=gl

devtools regression fix, approved for 68.0b5

Attachment #9066009 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified as fixed on Firefox 68.0b5 on Windows 10 x 64, Mac OS X 10.14 and on Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
Duplicate of this bug: 1556909

Comment on attachment 9066009 [details]
Bug 1552275 - Fix Copy Link context menu in DevTools Inspector markup view. r=gl

P1 for devtools, has tests, uplift verified on beta and had some bake time there with no reported regression, uplift approved for 67.0.2, thanks.

Attachment #9066009 - Flags: approval-mozilla-release? → approval-mozilla-release+

Thank you all for your help with uplifting this fix!

Adding QE+ for 67.0.2-build 2.

Flags: qe-verify+

Verified as fixed on Firefox 67.0.2 on Windows 10 x 64, Mac OS X 10.14 and on Ubuntu 18.04 x64.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.