Closed Bug 155241 Opened 22 years ago Closed 13 years ago

Installer should provide options for setting Moz as default HTTP:// protocol app [Set Moz to handle all user's internet shortcuts]

Categories

(SeaMonkey :: Installer, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: s.vanslyck, Unassigned)

References

Details

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

During the install dialog, or possibly at runtime in prefs, allow the user to
establish Moz as the default software to handle all internet shortcuts as
described in the user.win32 newsgroup on 7/1/2002:

===============
. . . [I]f you want to be a little more specific in the configurations
then you can bring up windows explorer -> View -> Folder Options -> File Types
and look for:

  Internet Shortcut
  Netscape Hypertext Document
  URL:http protocol

So forth and so on. This expands the editing capabilities for more
specific configurations . . . :-)

Reproducible: Always.
Steps to Reproduce: See description.
Actual Results:  See description.
Expected Results:  See description.
See attachment for example. I saved an e-mail message to the desktop, but Moz
won't re-open it without tweaking the OS. Even then, Moz insists on opening the
message in a browser window only.
Summary: Enhancement Request: Set Moz to handle all user's internet shortcuts → RFE: Set Moz to handle all user's internet shortcuts
so should mozilla take over callto: just because my system lists it?
Assignee: doron → law
Component: US General → File Handling
Product: Tech Evangelism → Browser
QA Contact: zach → sairuh
Version: unspecified → other
I don't know what you mean by "take over callto: just because my system lists it."
the summary is "set moz to handle all user's internet shortcuts", callto: is a 
registered url type on my system, i think. yep:
URL: CallTo Protocol
URL Protocol

rundll32.exe msconf.dll,CallToProtocolHandler %l

According to a strict reading of the summary callto: would be an internet 
shortcut and as such a subset of "all user's internet shortcuts".

That mozilla doesn't handle .eml, is its own bug, although i hope all issues 
discussed here already have reports. I'm still unclear about what you want.
If you're unclear then I'm in good company.

Here 'tis. When I installed [internet software program whose name escapes me] I
was asked at install-time "Do you want ___ to handle internet shortcuts?" When I
said yes, all desktop shortcuts (shadows, aliases, whatever) now opened via the
new software (IE, Netscape, whatever) instead of the old (Netscape, IE,
whatever). That's what I'm asking for. Thus, after installing Moz, or setting
this preference (however it may be implemented), I will thereupon be freed of
ever seeing another IE icon on my system or seeing anything opened in Outlook or
Outlook Express ever again. I hope this helps.
-> installer
Assignee: law → dveditz
Component: File Handling → Installer
QA Contact: sairuh → bugzilla
Summary: RFE: Set Moz to handle all user's internet shortcuts → Set Moz to handle all user's internet shortcuts
> ... [I]f you want to be a little more specific in the configurations
> then you can bring up windows explorer -> View -> Folder Options ->
> File Types and look for:
>
>  Internet Shortcut
>  Netscape Hypertext Document
>  URL:http protocol

I think Windows will launch shortcut files with whatever application
is set to handle the file type/protocal. So if Mozilla is set to
handle HTTP protocol, then all HTTP:// Internet shortcuts will be
routed to Mozilla.

As for HTML, doesn't the Installer already prompt the user for that?
Summary: Set Moz to handle all user's internet shortcuts → Installer should provide options for setting Moz as default HTTP:// protocol app [Set Moz to handle all user's internet shortcuts]
What about the mailto: protocols? I'm tired of seeing Outlook Express come up.
it's not up to the installer.
it all in Edit -> Prefs -> Advanced -> System
and in Edit -> Prefs -> Mail & Newsgroups
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago
Resolution: --- → INVALID
This but has NOT been resolved. I have every single option checked in prefs and
I STILL end up with IE and Outlook Express being called by shortcuts, document
links, and everything else! See comment #2.
reopening and marking as RFE (reguest for enhancement)
Shortcuts are not handled by changing prefs
Status: RESOLVED → UNCONFIRMED
QA Contact: bugzilla → gbush
Resolution: INVALID → ---
Summary: Installer should provide options for setting Moz as default HTTP:// protocol app [Set Moz to handle all user's internet shortcuts] → [RFE}Installer should provide options for setting Moz as default HTTP:// protocol app [Set Moz to handle all user's internet shortcuts]
*** Bug 165970 has been marked as a duplicate of this bug. ***
Hi All,

   The following registry key is incorrect:

          HKEY_CLASSES_ROOT\http\DefaultIcon
    
   It should point to "D:\Program Files\mozilla.org\Mozilla\mozilla.exe,0"
not "url.dll,0".  I changed mine by hand with regedit.

--Tony
Status: UNCONFIRMED → NEW
Ever confirmed: true
Does that change more than just the displayed icon? Does is set which program
opens the file?
Summary: [RFE}Installer should provide options for setting Moz as default HTTP:// protocol app [Set Moz to handle all user's internet shortcuts] → Installer should provide options for setting Moz as default HTTP:// protocol app [Set Moz to handle all user's internet shortcuts]
Hi Steve,

    My registry change only changes which icon is displayed.  The program
associated with the icon is different key:

     [HKEY_CLASSES_ROOT\http\shell\open\command]
     @="D:\\PROGRA~1\\MOZILLA.ORG\\MOZILLA\\MOZILLA.EXE -url \"%1\""

--Tony

If anyone would like my workaround, cut this out and save as a text file
called "FixHttp.reg"
------------ Snip -----------
REGEDIT4

[HKEY_CLASSES_ROOT\http\DefaultIcon]
@="D:\\Program Files\\mozilla.org\\Mozilla\\mozilla.exe,0"
Hi All,

   On my registry edit, change the path to match whatever icon you want to
display.  Most will only have to change the "D:" drive to "C:" drive

--Tony
As I understand it, double-clicking the resultant .reg file will overwrite the
current key with the new key.  ?
Hi Steve,

   That is the idea.  Make sure and verify the address that you 
want it to point to first.

--Tony
Severity: enhancement → normal
Has this been addressed in 1.2b?
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

I find that the preferences under Advanced|System do update the URL "file type"
handlers when changed.  However, there are no "file type" handlers listed for
the mailto: and news: protocols.

On the Navigator preferences page, 'Set Default Browser' changes the default
http:/https:/ftp: handlers, and the associations for .htm/.html/.xhtml/.xml
files.  It ignores .url files, which are Windows-specific shortcut files
(I think).

On the Mail & Newsgroup preference, checking "Use Mozilla as default mail
application" does NOT change the mailto: handler, nor news:, but it does
appear to change the Windows default-registry-lookup thing.  I know that with
Mozilla selected as my default, but without the mailto: handler tweaked, MS
apps such as IE and Office invoked Mozilla for email (MAPI?) but SecureCRT did
not, and Opera showed the default emailer as being OE.

The default handler for .eml is not changed, either.  The attachment from Comment 1 shows a command line to apply to that file type, but it didn't work for me.  What did work was 'mozilla -mail "file:///%1"' -- that opens the mail message in a standalone window, but not a typical message window.  I don't know
if there's a moz command option to open a file in a message window.

There were just today three threads I encountered in the newsgroups,
started by people seeking how to change the mailto: and news: settings.
shouldn't this get moved to "file handling" since this is not an installer issue...
The whole point of the bug - or enhancement request - as I have filed it is to
MAKE it an installer issue if it isn't one already. Other software handles user
option decisions at this point and Mozilla should as well.
Sorry about the extra-wide line in my previous comment.

Regarding the handling of .EML file, I said:
> I don't know if there's a moz command option to open a file 
> in a message window.
See Bug 11076 for more on this.

I guess I agree that this is not an installer issue per se, since if a pref
is changed within Mozilla, we want the program to make the changes.  

It would be nice, tho, if during install, there were an option in Custom
Install to prevent Mozilla from taking over the various file/protocol
associations.  (*Especially* to keep it from grabbing image types.)
I'm afraid I was less coherent than I wanted in comment 23.

Bug 121369 addresses some of the protocol/OS issues.  I suggested the following
over there:
That bug should be expanded to cover how all the protocols (including
http:, ftp:, gopher:) hook into Windows.  

This bug should be kept as an installer bug, regarding offering an option
at install to prevent Mozilla from grabbing protocols and file-extensions
by default, as I suggested in my previous post.
> prevent Mozilla from grabbing protocols 

I *want* Mozilla to grab protocols. I *never* *ever* want to see IE or OE.

Howmsoever, however, letting the user make those selections at install time
would make everyone happy.
Product: Browser → Seamonkey
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
Well, this user can certainly confirm it for Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.20) Gecko/20081217 Firefox/2.0.0.20 . For Heaven's sake please fix this. It is no end irritating to have to set the URL open with's every single time I update Firefox.
Assignee: dveditz → installer
(In reply to comment #27)
> Well, this user can certainly confirm it for Mozilla/5.0 (Windows; U; Windows
> NT 5.1; en-US; rv:1.8.1.20) Gecko/20081217 Firefox/2.0.0.20 .

Irrelevant, as this is a SeaMonkey bug.

Frank, is this still an issue with current NSIS installers?
So where do we report SeaMonkey bugs, if not here?
(In reply to comment #29)
> So where do we report SeaMonkey bugs, if not here?

This is the right component for SeaMonkey installer bugs, but not for Firefox bugs, and your comment #27 was talking about Firefox, not SeaMonkey.

The question is if this is still an issue with SeaMonkey 2 installers.
> Frank, is this still an issue with current NSIS installers?
Ping mcsmurf
Not an issue anymore, the installer does set http/https/ftp to SeaMonkey.
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: