Closed Bug 1552420 Opened 4 months ago Closed 4 months ago

Mocha tests are failing

Categories

(DevTools :: Console, defect, P1)

defect

Tracking

(firefox68 fixed)

RESOLVED FIXED
Firefox 68
Tracking Status
firefox68 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

(Regression)

Details

Attachments

(1 file)

Bug 1547084 introduced a call to pointPrecedes which is loaded with ChromeUtils, but ChromeUtils is not defined in mocha's context.

This fixes the test failures.
We remove the requireHacker case for ChromeUtils,
since it's never required.

(In reply to Nicolas Chevobbe [:nchevobbe] from comment #3)

what's weird is that treeherder doesn't see this as a failing test: https://treeherder.mozilla.org/#/jobs?repo=try&revision=ad0b2910bfcabed093761a94fdb3aef08c6050a9&selectedJob=246993633 is green, but looking at the log https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=246993633&repo=try&lineNumber=135 , you can see the error.

Yes, our try runner is a bit weak, as we are parsing the out/err log from Jest and Mocha and try to identify errors based on regexp.

I will try to improve this by using json base reporters.

See Also: → 1552123
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5a1c37d11ebc
Add a mock for ChromeUtils in mocha tests. r=jdescottes.
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
You need to log in before you can comment on or make changes to this bug.