Closed Bug 1552979 Opened 2 years ago Closed 1 year ago

Allow modules to be compiled directly from UTF-8

Categories

(Core :: JavaScript Engine, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: Waldo, Assigned: Waldo)

References

(Blocks 1 open bug)

Details

Attachments

(6 files)

No description provided.
Priority: -- → P1
Pushed by jwalden@mit.edu:
https://hg.mozilla.org/integration/mozilla-inbound/rev/38beafecef9b
Templatize {Script,Module}ParseTask by Unit as a step toward enabling off-thread parsing of UTF-8 source.  r=arai
https://hg.mozilla.org/integration/mozilla-inbound/rev/41adfcfb70bf
Make StartOffThreadParseTask accept UniquePtr<ParseTask> and not just a raw ParseTask* borrowed (gulp) from one.  r=arai
https://hg.mozilla.org/integration/mozilla-inbound/rev/3ce85949f2e1
Rename one CompileModule overload to ParseModule to make it easier to distinguish them, both mentally and in searches.  r=arai
https://hg.mozilla.org/integration/mozilla-inbound/rev/cb71e51f8cad
Add ParseModule and CompileModule overloads for UTF-8.  r=arai
https://hg.mozilla.org/integration/mozilla-inbound/rev/6fac68354ef4
Begin fleshing out off-thread script/module compilation support for UTF-8.  r=arai
https://hg.mozilla.org/integration/mozilla-inbound/rev/d22bd25523e5
Make JS::CompileModule return the module directly, rather than by outparam duplicative of a boolean return value.  r=arai
https://hg.mozilla.org/integration/mozilla-inbound/rev/d31060048c95
Add a JS::CompileModule overload for direct UTF-8 compilation.  r=arai

Whoops, I added some JSAPI entrypoints but not implementations of them. Let's get on that.

Keywords: leave-open
Pushed by jwalden@mit.edu:
https://hg.mozilla.org/integration/mozilla-inbound/rev/78f45a2b47cb
Define off-thread compilation APIs, of modules and scripts, for UTF-8.  r=arai
Keywords: leave-open
Duplicate of this bug: 1552980
Duplicate of this bug: 1543819
You need to log in before you can comment on or make changes to this bug.