Closed Bug 1553290 Opened 5 months ago Closed 5 months ago

SupportMenu policy isn't working in the hamburger menu

Categories

(Firefox :: Enterprise Policies, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 69
Tracking Status
firefox-esr68 68+ fixed
firefox68 --- fixed
firefox69 --- verified

People

(Reporter: mkaply, Assigned: mkaply)

Details

Attachments

(1 file)

The support menu policy is working in the dropdown menu but not in the hamburger menu.

Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/96402748b816
Get support menu href direct from policy. r=jaws
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

Comment on attachment 9067135 [details]
Bug 1553290 - Get support menu href direct from policy.

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: Policy related
  • User impact if declined: New policy (SupportMenu) won't work on 68.
  • Fix Landed on Version: 69
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Automated test, policy only, on nightly for a while.
  • String or UUID changes made by this patch:

Beta/Release Uplift Approval Request

  • User impact if declined: New policy (SupportMenu) won't work on 68.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Automated test, policy only, on nightly for a while.
  • String changes made/needed:
Attachment #9067135 - Flags: approval-mozilla-release?
Attachment #9067135 - Flags: approval-mozilla-esr68?

Looks like there would have been ample time to test this while it was on nightly and uplift before the last minute, I'd rather not take this in rc2.

It was just a miss on my part. I forgot to uplift.

Flags: qe-verify+
QA Whiteboard: [qa-triaged]

This issue is verified fixed using Firefox 69.0b3 (BuildId:20190708182549) on Windows 10 64bit, macOS 10.15 and Ubuntu 18.04 64bit.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

jcristau, now that this has been/tested and verified, wanted to reask for esr/68. Tx.

Flags: needinfo?(jcristau)

Comment on attachment 9067135 [details]
Bug 1553290 - Get support menu href direct from policy.

enterprise policy fix, approved for 68.0.1 and 60.1esr

Flags: needinfo?(jcristau)
Attachment #9067135 - Flags: approval-mozilla-release?
Attachment #9067135 - Flags: approval-mozilla-release+
Attachment #9067135 - Flags: approval-mozilla-esr68?
Attachment #9067135 - Flags: approval-mozilla-esr68+

(In reply to Julien Cristau [:jcristau] from comment #9)

approved for 68.0.1 and 60.1esr

Please clarify in which ESR versions that fix shall ship: 68.0.1esr, 68.1.0esr, 60.8.1esr, 60.9.0esr

Flags: needinfo?(jcristau)

Any 68 ESRs, not the 60 ESR.

Is 68.1.0esr going to be shipped from the 68.0.1 esr branch?

Flags: needinfo?(jcristau)

(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #10)

(In reply to Julien Cristau [:jcristau] from comment #9)

approved for 68.0.1 and 60.1esr

Please clarify in which ESR versions that fix shall ship: 68.0.1esr, 68.1.0esr, 60.8.1esr, 60.9.0esr

Sorry, I meant 68.1esr.

(In reply to Mike Kaply [:mkaply] from comment #11)

Any 68 ESRs, not the 60 ESR.

Is 68.1.0esr going to be shipped from the 68.0.1 esr branch?

No.

Per discussion with jcristau, we're uplifting this to 68.0.1esr also to maintain parity with the non-ESR 68.0.1 release and hopefully avoid some confusion.

You need to log in before you can comment on or make changes to this bug.