Japanese Input Method on Linux use wrong font to display over-the-spot pre-edit region

VERIFIED WONTFIX

Status

()

Core
Internationalization
P5
normal
VERIFIED WONTFIX
19 years ago
18 years ago

People

(Reporter: Frank Tang, Assigned: Hidetoshi Tajima)

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-][PDT-])

(Reporter)

Description

19 years ago
Steps to reproduce-
1. Install input method - read news://news.mozilla.org/37EFAA9B.CD598251%40netscape.com for details
2. switch to Japanese input method.
3. start type something,SeaMonkey use different font than the insertion point to display the pre-edit region.

Updated

19 years ago
Assignee: erik → tajima

Comment 1

19 years ago
Tague, here again, the font issue might be something to consider in your new
proposal for the input method architecture.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

19 years ago
In over-the-spot editing style of XIM, we need to set fontset information to XIM
whenever it needs to be changed. That's especially important in HTML editor to
achieve WYSWYG.
(Reporter)

Updated

18 years ago
Blocks: 16127
(Assignee)

Updated

18 years ago
Target Milestone: M12

Updated

18 years ago
Summary: Japanese Input Method on Linux use wrong font to display over-the-spot pre-edit region → [BETA]Japanese Input Method on Linux use wrong font to display over-the-spot pre-edit region

Comment 3

18 years ago
This still happen in 12-01-09 Linux build.

Updated

18 years ago
Target Milestone: M12 → M13

Comment 4

18 years ago
Not dogfood.  Moved to M13.
(Reporter)

Updated

18 years ago
Whiteboard: have fix to use the right SIZE in my local tree.

Updated

18 years ago
Whiteboard: have fix to use the right SIZE in my local tree. → ftang: have fix to use the right SIZE in my local tree.
(Reporter)

Comment 5

18 years ago
I have fix the size part.
(Reporter)

Updated

18 years ago
Assignee: tajima → bobj
Status: ASSIGNED → NEW
Whiteboard: ftang: have fix to use the right SIZE in my local tree.
(Reporter)

Comment 6

18 years ago
clean up the status whiteboard.
I really don't think the face and color issue is a beta stopper. reassign to
bobj.

Updated

18 years ago
Assignee: bobj → erik
Target Milestone: M13 → M14

Comment 7

18 years ago
Reassigned to Erik for M14

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 8

18 years ago
Moving some of my M14s to M15. Please add comments if you disagree.
Target Milestone: M14 → M15

Comment 9

18 years ago
Due to Beta indication in Summary, putting beta1 into keyword field.
Keywords: beta1

Comment 10

18 years ago
Putting on PDT- radar for beta1.
Whiteboard: [PDT-]

Updated

18 years ago
Summary: [BETA]Japanese Input Method on Linux use wrong font to display over-the-spot pre-edit region → Japanese Input Method on Linux use wrong font to display over-the-spot pre-edit region

Comment 11

18 years ago
Toshi, I'm reassigning this Unix IME bug to you.
Assignee: erik → tajima
Status: ASSIGNED → NEW
Target Milestone: M15
(Assignee)

Comment 12

18 years ago
accepted anyway.
Status: NEW → ASSIGNED

Comment 13

18 years ago
Nominating this bug to beta2.
Keywords: beta1 → nsbeta2
(Assignee)

Comment 14

18 years ago
I presume this bug is now of low priority since on-the-spot is using as default
input-style
in Japanese XIM. Do we really need a fix for beta2? If possible, I'd like to
mark 
"WONTTOFIX".
Target Milestone: --- → M20
(Assignee)

Updated

18 years ago
Priority: P3 → P5

Comment 15

18 years ago
Putting on [nsbeta2-] radar. Not critical to beta2.
Whiteboard: [PDT-] → [nsbeta2-][PDT-]
(Assignee)

Comment 16

18 years ago
We won't fix this. OnTheSpot is getting stable and good enough for japanese
input.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX
Target Milestone: M20 → Future

Comment 17

18 years ago
Verified as Wontfix.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.