Closed Bug 1553311 Opened 6 months ago Closed 5 months ago

Perma browser_browser_languages_subdialog.js failures when Gecko version increases to 70 on 2019-07-08

Categories

(Firefox :: Preferences, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox67.0.1 --- unaffected
firefox68 --- unaffected
firefox69 + verified

People

(Reporter: aryx, Assigned: mstriemer)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Version increase simulation: https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=1a7d27e9716b885fa3e1a697d896781f76d0c6fb&searchStr=browser-chrome&selectedJob=247550751

Failure log (second failing test): https://treeherder.mozilla.org/logviewer.html#?job_id=247550751&repo=try

TEST-UNEXPECTED-FAIL | browser/components/preferences/in-content/tests/browser_browser_languages_subdialog.js | The events are recorded correctly - [] deepEqual [["manage","main","16044"],["search","dialog","16044"],["add","dialog","16044",{"installId":6}],["cancel","dialog","16044"]] - JS frame :: chrome://mochitests/content/browser/browser/components/preferences/in-content/tests/browser_browser_languages_subdialog.js :: assertTelemetryRecorde

Fails because intl.ui.browserLanguage expires in Gecko 70: https://searchfox.org/mozilla-central/rev/6c9f60f8cc064a1005cd8141ecd526578ae9da7a/toolkit/components/telemetry/Events.yaml#1152

Flags: needinfo?(mstriemer)
Priority: -- → P1
Attached file data-review.txt
Flags: needinfo?(mstriemer)
Attachment #9068567 - Flags: data-review?(chutten)
Comment on attachment 9068567 [details]
data-review.txt

DATA COLLECTION REVIEW RESPONSE:

    Is there or will there be documentation that describes the schema for the ultimate data set available publicly, complete and accurate?

Yes. This collection is Telemetry so is documented in its definitions file [Events.yaml](https://hg.mozilla.org/mozilla-central/file/tip/toolkit/components/telemetry/Events.yaml) and the [Probe Dictionary](https://telemetry.mozilla.org/probe-dictionary/).

    Is there a control mechanism that allows the user to turn the data collection on and off?

Yes. This collection is Telemetry so can be controlled through Firefox's Preferences.

    If the request is for permanent data collection, is there someone who will monitor the data over time?

No. This collection will expire in six more months (I presume in Firefox 75).

    Using the category system of data types on the Mozilla wiki, what collection type of data do the requested measurements fall under?

Category 2, Interaction.

    Is the data collection request for default-on or default-off?

Default on for all channels.

    Does the instrumentation include the addition of any new identifiers?

No.

    Is the data collection covered by the existing Firefox privacy notice?

Yes.

    Does there need to be a check-in in the future to determine whether to renew the data?

Yes. :mstriemer is responsible for renewing or removing the collection before it expires in Firefox 75.

---
Result: datareview+

Clear to renew to 75.
Attachment #9068567 - Flags: data-review?(chutten) → data-review+
Assignee: nobody → mstriemer
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fb13459f32e4
Renew browser languages telemetry until 75 r=janerik
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
You need to log in before you can comment on or make changes to this bug.