Closed Bug 1553377 Opened 1 year ago Closed 1 year ago

Smart keywords at beginning of URLs are broken in 67.0

Categories

(Firefox :: Bookmarks & History, defect)

67 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1401401

People

(Reporter: neeektj, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

  1. In Firefox 66.x or lower, create a new smart keyword in the format http://%s.example.com (i.e., with the keyword at the beginning of the URL)
  2. Verify the keyword search works
  3. Upgrade to Firefox 67.0
  4. Try using the smart keyword search
  5. Try to delete the smart keyword bookmark

Actual results:

  • Smart keyword searches in this format work in Firefox 66.x, but not in 67.0
  • Cannot delete these smart keyword bookmarks, using any of the delete key, context menu, or 'organize' menu in the bookmarks library

Expected results:

  • Expected smart keyword searches in this format to continue to work in Firefox 67+. It's no longer possible to add smart keyword searches in this format, so this may be intentional.
  • If this is intentional, we should be able to delete the bookmark
Component: Untriaged → Bookmarks & History

We don't support anymore replacement in the domain part of the url, because it generates invalid urls, and thus creates problems to the internal APIs.

The removal problem is tracked in bug 1401401

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1401401
You need to log in before you can comment on or make changes to this bug.