Closed Bug 1553413 Opened 7 months ago Closed 7 months ago

TypeError: data is null in PrivacyFilter.jsm

Categories

(Firefox :: Session Restore, defect, P1)

66 Branch
defect
Points:
2

Tracking

()

RESOLVED FIXED
Firefox 69
Iteration:
69.1 - May 13 - 26
Tracking Status
firefox-esr60 --- unaffected
firefox67 + fixed
firefox67.0.1 --- wontfix
firefox68 + fixed
firefox69 --- fixed

People

(Reporter: glandium, Assigned: mikedeboer)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

This message happens repeatedly in the browser console on Firefox 67:

TypeError: data is nullPrivacyFilter.jsm:49:9

I don't know if that prevents further code to run.

(In reply to Mike Hommey [:glandium] from comment #0)

I don't know if that prevents further code to run.

I think it most certainly does! Thanks for filing.

Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Priority: -- → P1

[Tracking Requested - why for this release]: This JS error may cause an unexpected degraded session restore experience. The return type of the form data collector changed slightly in bug 1497146, which the PrivacyFilter needs to take into account.

No longer blocks: 1497146
Keywords: regression
Regressed by: 1497146
Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bfb0684033ad
Update and harden form data filtering for privacy to account for no data being passed in. r=dao
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

Mike, do you want to request uplift to beta/release?

Flags: needinfo?(mdeboer)
Version: 67 Branch → 66 Branch

Comment on attachment 9066650 [details]
Bug 1553413 - Update and harden form data filtering for privacy to account for no data being passed in. r?dao

Beta/Release Uplift Approval Request

  • User impact if declined: Prevents a JavaScript error to be thrown, which may significantly degrade sessionstore reliability and performance.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Not risky, since it's fixing an actual error with a very small not-null-check.
  • String changes made/needed:
Flags: needinfo?(mdeboer)
Attachment #9066650 - Flags: approval-mozilla-release?
Attachment #9066650 - Flags: approval-mozilla-beta?

Comment on attachment 9066650 [details]
Bug 1553413 - Update and harden form data filtering for privacy to account for no data being passed in. r?dao

regression fix, approved for 68.0b6

Attachment #9066650 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Do you think this would be important for the 67.0.1 trailhead release? Or can it wait till a 67.0.2?

Flags: needinfo?(mdeboer)

After discussion in team triage today, let's defer till 67.0.2.

Comment on attachment 9066650 [details]
Bug 1553413 - Update and harden form data filtering for privacy to account for no data being passed in. r?dao

P1, verified on beta, fix approved for 67.0.2, thanks.

Attachment #9066650 - Flags: approval-mozilla-release? → approval-mozilla-release+
Iteration: --- → 69.1 - May 13 - 26
Points: --- → 2
Flags: needinfo?(mdeboer)
Duplicate of this bug: 1553417
You need to log in before you can comment on or make changes to this bug.