Closed Bug 1553433 Opened 5 months ago Closed 4 months ago

[Win] Text inside the Install/Uninstall Firefox prompt turns blank in high contrast

Categories

(Firefox :: Installer, defect, P1)

All
Windows
defect

Tracking

()

VERIFIED FIXED
Firefox 69
Tracking Status
firefox-esr68 --- wontfix
firefox67 --- wontfix
firefox68 --- wontfix
firefox69 --- verified

People

(Reporter: Anca, Assigned: mhowell)

References

Details

Attachments

(2 files)

Attached image screenshot issue .png

[Affected versions]:

  • 69.0a1 (2019-05-21)
  • 68.0b3
  • 67.0

[Affected platforms]:

  • Windows 10 x64
  • Windows 8.1 x64

[Steps to reproduce]:

  1. Turn on high contrast (except white)
  2. Install any affected Firefox version
  3. Uninstall the Firefox build

[Expected result]:

  • Text inside the Install/Uninstall window is clear and visible.

[Actual result]:

  • There is no text inside the Install/Uninstall window.

[Regression range]:

  • This doesn’t seem to be a regression, reproducible way back to Fx 49.

[Additional Notes]:

  • Issue not reproducible with high contrast white.
  • Issue reproducible with Full installer and Stub installer (only for uninstall prompt).
Priority: -- → P2

I'm working on this now.

The full installer has exactly the same problem for the same reason, so I'll fix it here also.

Assignee: nobody → mhowell
Status: NEW → ASSIGNED
Priority: P2 → P1

The stub installer is also kind of affected, but it's a milder case (the text shows up as black-on-white, which is pretty visible, it's just not the colors that are configured), and it's harder to fix, so that's getting a separate bug.

See Also: → 1555765

We can use MUI_BGCOLOR to change the background color, but there's no way to
globally override the text color, so we additionally need to set that on every
affected control in the Show functions (we have to wait until Show because
that's the earliest point that the controls have been created and we can get
handles to them).

This patch fixes both the full installer and the uninstaller.

Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/358e1d1cc617
Use the system theme's colors for the installer wizard welcome/finish pages. r=agashlin
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

Is this something we may want to fix in esr68?

I don't know if this is serious enough to uplift this late; this bug has been there since the launch of Windows 8 and never been reported until now, and ESR users are less likely to be running the uninstaller GUI at all. I'd be on board with adding this to 68.1 or 68.2 though.

Flags: qe-verify+

This issue is verified fixed with Beta 69.0b6 on Windows 10 x64 and Windows 7 x86.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.