Closed Bug 1553474 Opened 5 months ago Closed 5 months ago

"Remove bookmark" option is displayed for pages that were not bookmarked

Categories

(Firefox for Android :: Awesomescreen, defect)

Firefox 68
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 69
Tracking Status
firefox67 --- unaffected
firefox68 --- verified
firefox69 --- fixed

People

(Reporter: eliza.balazs, Assigned: diana.iacos)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Environment:
Devices:
OnePlus 5T (Android 9);
Nexus 6P (Android 8.1.0);
Samsung Galaxy S8 (Android 9).

Builds:
Nightly 68.0a1 (2019-05-17);
Beta 68.0b3

Steps to reproduce:

  1. Navigate to a Recommended by Pocket page;
  2. Go back to the about:home page;
  3. Long tap on that page from the Top Sites grid view;
  4. Pay attention to the "Bookmark" option from the Context Menu.

Expected result:
Page is not bookmarked.

Actual result:
"Remove bookmark" option is displayed.

Notes:

Hi!
I tested this with Nexus 6P (Android 8.1.0) and I found a regression:

Last good revision: 387e71baf2efedfb90a287a378dc2ed45a1161cd
First bad revision: 8e592445e44255edb05d4d21bd3ecbda21a1ede1

Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=387e71baf2efedfb90a287a378dc2ed45a1161cd&tochange=8e592445e44255edb05d4d21bd3ecbda21a1ede1

This was caused by Bug 1506231.

Flags: needinfo?(petru.lingurar)
Keywords: regression
Regressed by: 1506231
Assignee: nobody → diana.iacos
Status: NEW → ASSIGNED
Flags: needinfo?(petru.lingurar)
Keywords: checkin-needed

Pushed by malexandru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bfd32880a473
"Remove bookmark" option is displayed for pages that were not bookmarked; r=petru

Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
Flags: qe-verify+

Diana, can you please request uplift of your bookmark fix to Fennec 68 Beta? We'll be supporting Fennec 68 in ESR until mid-2020 so it would be nice to have your fix.

Flags: needinfo?(diana.iacos)

Comment on attachment 9067696 [details]
Bug 1553474 - "Remove bookmark" option is displayed for pages that were not bookmarked; r?petru

Beta/Release Uplift Approval Request

  • User impact if declined: The users will not be able to bookmark a page when they long press on an item from Top Sites grid view, because only "Remove bookmark" option is displayed even if the page is not bookmarked.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce:
    1. Navigate to a Recommended by Pocket page;
    2. Go back to the about:home page;
    3. Long tap on that page from the Top Sites grid view;
    4. Pay attention to the "Bookmark" option from the Context Menu.

Expected result:
Page is not bookmarked.

Actual result:
"Remove bookmark" option is displayed.

  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The changes are not risky because we did only some small changes, such as adding a condition to check the value of a column.
  • String changes made/needed: No strings were added.
Flags: needinfo?(diana.iacos)
Attachment #9067696 - Flags: approval-mozilla-beta?
QA Whiteboard: [qa-triaged]

Comment on attachment 9067696 [details]
Bug 1553474 - "Remove bookmark" option is displayed for pages that were not bookmarked; r?petru

fennec fix for 68.0b7

Attachment #9067696 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Hi!
I tested this on the latest version of Nightly 68.0a1 (2019-06-01) with OnePlus 5T (Android 9), Nexus 6P (Android 8.1.0), Huawei Honor 8 (Android 7.0) and I could not reproduce the issue.
I am leaving the qe-verify+ flag until we verify this on Beta 68.0b7 as well.
Thanks!

QA Whiteboard: [qa-triaged]

Hi!
Verified as fixed on Beta 68.0b7 with OnePlus 5T (Android 9) and Motorola Nexus 6 (Android 7.1.1).
Due to my findings, I'll mark this issue as verified.
Thanks.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.