Closed Bug 1553548 Opened 3 months ago Closed 3 months ago

CSS `contain` needs to inherit from table to table-wrapper-box

Categories

(Core :: Layout: Tables, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: dholbert, Assigned: dholbert)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

table elements have an anonymous table-wrapper-box which wraps the table-caption and the table, and the table-wrapper-box is the real child of whatever the table's parent-element is.

We need to have contain styling be inherited through from the table to its table-wrapper-box, like we do for lots of other properties. Right now, layout containment and paint containment don't work on tables because we fail to do this.

Here's a testcase that currently fails but will pass when we fix this bug.

This testcase will be included with my patch as WPT "contain-paint-table-002.html". (I'll also have a -001 test which I'm not bothering to attach because it already passes by virtue of the fact that we do honor contain:paint on the table box itself.)

As for contain:layout, that is already covered by this WPT test (which we currently fail):
https://hg.mozilla.org/mozilla-central/raw-file/tip/testing/web-platform/tests/css/css-contain/contain-layout-baseline-005.html

The second item in the final row is an inline-table, which is mispositioned due to this bug here. This bug here will fix that issue, and bug 1552287 will fix the rest of that test.

Blocks: 1552287
Attachment #9066793 - Attachment description: Bug 1553548: Make table-wrapper-box inherit CSS "contain" from table box. r?TYLin → Bug 1553548: [css-contain] Make table-wrapper-box inherit CSS "contain" from table box. r?TYLin
Pushed by dholbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/afb705ca89e1
[css-contain] Make table-wrapper-box inherit CSS "contain" from table box. r=TYLin
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/16977 for changes under testing/web-platform/tests
Upstream web-platform-tests status checks passed, PR will merge once commit reaches central.
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Upstream PR merged
Regressions: 1555757
You need to log in before you can comment on or make changes to this bug.