Closed Bug 1553586 Opened 3 months ago Closed 3 months ago

Need to add JSON as a type for ExtensionSettings so it can be used via GPO

Categories

(Firefox :: Enterprise Policies, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 69
Tracking Status
firefox-esr68 68+ verified
firefox68 --- verified
firefox69 --- verified
firefox70 --- verified

People

(Reporter: mkaply, Assigned: mkaply)

Details

Attachments

(1 file, 1 obsolete file)

Complex policies (like ExtensionSettings) end up getting set via a string in group policy with the JSON.

For that to work, the policy needs JSON as a type in its schema.

Priority: -- → P1
Attachment #9067177 - Attachment is obsolete: true

Bugbug thinks this bug is a task, but please change it back in case of error.

Type: defect → task
Type: task → defect
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/51618e4ce345
Need JSON as a type for ExtensionSettings for GPO to work. r=jaws
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

Test for this is to verify that something like this works:

{
"policies": {
"ExtensionSettings": "{"*": {"installation_mode": "blocked"}}"
}
}

versus

{
"policies": {
"ExtensionSettings": {
"*": {
"installation_mode": "blocked"
}
}
}
}

Flags: qe-verify+

Comment on attachment 9067104 [details]
Bug 1553586 - Need JSON as a type for ExtensionSettings for GPO to work.

Beta/Release Uplift Approval Request

  • User impact if declined: Unable to use new ExtensionSettings policy with GPO on Windows.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Steps in bug, have already requested.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Minimal policy only change
  • String changes made/needed:

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: This was a missed uplift for 68 that is needed for one of the new policies in 68.
  • User impact if declined: Unable to use new ExtensionSettings policy with GPO on Windows.
  • Fix Landed on Version: 69
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Minimal policy only change
  • String or UUID changes made by this patch:
Attachment #9067104 - Flags: approval-mozilla-release?
Attachment #9067104 - Flags: approval-mozilla-esr68?
QA Whiteboard: [qa-triaged]

Tested the new policy format in Fx70.0a1 on macOS10.14, ubuntu 18.04 and windows 10 x64. The policy is correctly registered and applied (no addons can be installed).

Please note that the correct policy to apply is:

{
"policies": {
"ExtensionSettings": "{\"*\": {\"installation_mode\": \"blocked\"}}"
}
}

The issue is also verified fixed in Fx69.0b4 on macOS 10.14, ubuntu 18.04 and windows 10 x64. The policy is correctly registered and applied (no addons can be installed).

Comment on attachment 9067104 [details]
Bug 1553586 - Need JSON as a type for ExtensionSettings for GPO to work.

policy fix, approved for 68.0.1 and 68.1esr

Attachment #9067104 - Flags: approval-mozilla-release?
Attachment #9067104 - Flags: approval-mozilla-release+
Attachment #9067104 - Flags: approval-mozilla-esr68?
Attachment #9067104 - Flags: approval-mozilla-esr68+

Per discussion with jcristau, we're uplifting this to 68.0.1esr also to maintain parity with the non-ESR 68.0.1 release and hopefully avoid some confusion.

Tested the fix in Fx68.0.1RC and Fx68.0.1ESR on windows 10 x64, macOS 10.14 and ubuntu 18.04 x64. The ExtensionSettings are correctly applied with json as a type.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.