Closed Bug 1554280 Opened 7 months ago Closed 7 months ago

Expose `IsProcessRoot` on Window Global Actors

Categories

(Core :: DOM: Content Processes, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla69
Fission Milestone M3
Tracking Status
firefox69 --- fixed

People

(Reporter: Nika, Assigned: Nika)

References

Details

Attachments

(2 files)

The hope is that this information being available on both sides can allow something like bug 1552186 to be implemented more easily or in JS code.

Figured it would be fairly straightforward to just expose this info, and it might be helpful for that.

Type: defect → enhancement
Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9b03e3640b09
Part 1: Expose the ContentParentId of a WindowGlobalActor, r=mconley
https://hg.mozilla.org/integration/autoland/rev/14c9835bfca5
Part 2: Add an IsProcessRoot() getter to WindowGlobalActor, r=mconley
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Regressions: 1565489
Duplicate of this bug: 878180
You need to log in before you can comment on or make changes to this bug.