crash if i shrink fonts with "ctrl -"

RESOLVED WORKSFORME

Status

()

Core
Layout
--
critical
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: David Caplan, Assigned: kill this account)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1a) Gecko/20020610
BuildID:    20020610

Crashes on supplied page (not sure yet if it is the only one, but probably
not)when "ctrl -" used to shrink fonts, excessive "ctrl +" might have the same
effect. 
Mozilla outputs this message: /usr/local/mozilla/run-mozilla.sh: line 72: 18661
Floating point exception$prog ${1+"$@"}
Could also be a bug in gtk/gdk libraries.

Reproducible: Always
Steps to Reproduce:
1.Go to page http://www.coffeehaus.com/favorites.html or any other one maybe?
2.Press "ctrl -"
3.repeat 2 until crash

Actual Results:  Crash and:
Mozilla outputs this message: /usr/local/mozilla/run-mozilla.sh: line 72: 18661
Floating point exception$prog ${1+"$@"}

Expected Results:  Nothing?
(Reporter)

Comment 1

16 years ago
Mozilla is NOT affected by using "ctrl +"
Reporter:
Do you use a mozilla.org build or do you compiled yourself or do you use a
distributed build ?

Can you add a talkback ID of that crash ?
(Reporter)

Comment 3

16 years ago
If i can remember correctly, this is the mozillal 1.1a build.
I've never posted a bug before :) How do I get a talkback id. I actually
installed mozilla without talkback enabled (i think)
You need a talkback enabled build...
After talkback submitted the crash run mozilla/components/talkback to get the ID.

You should be able to install talkback in your existing build if you use a
mozilla.org not rpm based build.
Be sure that software installation and Javascript is enabled and click on this link:
ftp://ftp.mozilla.org/pub/mozilla/releases/mozilla1.1a/linux-xpi/talkback.xpi
(Reporter)

Comment 5

16 years ago
Talkback ID: TB7983965X
There is no stack attached to that incident ID.
Search by email gives:

nsFontMetricsGTK::RealizeFont()
nsFontMetricsGTK::Init()
nsFontCache::GetMetricsFor()
DeviceContextImpl::GetMetricsFor()
nsFormControlHelper::GetFrameFontFM()
nsGfxTextControlFrame2::CalculateSizeStandard()
nsGfxTextControlFrame2::ReflowStandard()
nsGfxTextControlFrame2::GetPrefSize()
nsBoxFrame::Reflow()
nsGfxTextControlFrame2::Reflow()
nsLineLayout::ReflowFrame()
nsBlockFrame::ReflowInlineFrame()
nsBlockFrame::DoReflowInlineFrames()
nsBlockFrame::DoReflowInlineFramesAuto()
nsBlockFrame::ReflowInlineFrames()
nsBlockFrame::ReflowLine()
nsBlockFrame::ReflowDirtyLines()
nsBlockFrame::Reflow()
nsContainerFrame::ReflowChild()
nsTableCellFrame::Reflow()
nsContainerFrame::ReflowChild()
nsTableRowFrame::ReflowChildren()
nsTableRowFrame::Reflow()
nsContainerFrame::ReflowChild()
nsTableRowGroupFrame::ReflowChildren()
nsTableRowGroupFrame::Reflow()
nsContainerFrame::ReflowChild()
nsTableFrame::ReflowChildren()
nsTableFrame::Reflow()
nsContainerFrame::ReflowChild()
nsTableOuterFrame::OuterReflowChild()
nsTableOuterFrame::Reflow()
nsBlockReflowContext::DoReflowBlock()
nsBlockReflowContext::ReflowBlock()
nsBlockFrame::ReflowBlockFrame()
nsBlockFrame::ReflowLine()
nsBlockFrame::ReflowDirtyLines()
nsBlockFrame::Reflow()
nsBlockReflowContext::DoReflowBlock()
nsBlockReflowContext::ReflowBlock()
nsBlockFrame::ReflowBlockFrame()
nsBlockFrame::ReflowLine()
nsBlockFrame::ReflowDirtyLines()
nsBlockFrame::Reflow()
nsBlockReflowContext::DoReflowBlock()
nsBlockReflowContext::ReflowBlock()
nsBlockFrame::ReflowBlockFrame()
nsBlockFrame::ReflowLine()
nsBlockFrame::ReflowDirtyLines()
nsBlockFrame::Reflow()
nsBlockReflowContext::DoReflowBlock()
nsBlockReflowContext::ReflowBlock()
nsBlockFrame::ReflowBlockFrame()
nsBlockFrame::ReflowLine()
nsBlockFrame::ReflowDirtyLines()
nsBlockFrame::Reflow()
nsContainerFrame::ReflowChild()
CanvasFrame::Reflow()
nsBoxToBlockAdaptor::Reflow()
nsBoxToBlockAdaptor::DoLayout()
nsBox::Layout()
nsScrollBoxFrame::DoLayout()
nsBox::Layout()
nsContainerBox::LayoutChildAt()
nsGfxScrollFrameInner::LayoutBox()
nsGfxScrollFrameInner::Layout()
nsGfxScrollFrame::DoLayout()
nsBox::Layout()
nsBoxFrame::Reflow()
nsGfxScrollFrame::Reflow()
nsContainerFrame::ReflowChild()
ViewportFrame::Reflow()
PresShell::StyleChangeReflow()
nsPresContext::ClearStyleDataAndReflow()
DocumentViewerImpl::SetTextZoom()
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod()
XPC_WN_GetterSetter()
js_Invoke()
js_InternalInvoke()
js_SetProperty()
js_Interpret()
js_Invoke()
js_InternalInvoke()
js_SetProperty()
js_Interpret()
js_Invoke()
js_InternalInvoke()
JS_CallFunctionValue()
nsJSContext::CallEventHandler()
nsJSEventListener::HandleEvent()
nsXBLPrototypeHandler::ExecuteHandler()
nsXBLWindowHandler::WalkHandlersInternal()
nsXBLWindowKeyHandler::WalkHandlers()
nsXBLWindowKeyHandler::KeyPress()
nsEventListenerManager::HandleEvent()
nsXULDocument::HandleDOMEvent()
nsXULElement::HandleDOMEvent()
nsXULElement::HandleDOMEvent()
nsXULElement::HandleDOMEvent() 
Keywords: crash
(Reporter)

Comment 8

16 years ago
I'm not sure if this is important, but here is the all the data from the crash:
http://david.ath.cx/TB7983965X.txt
(Assignee)

Comment 9

16 years ago
could you try setting the environment variable NS_FONT_DEBUG=FFF, capture moz's
output, and attach it to this bug?
(Reporter)

Comment 10

16 years ago
There was no output...
or i missed something :)
(Assignee)

Comment 11

16 years ago
it should be hundereds/thousands of lines. here is a typical output:
attachment 89958 [details]

For csh

 setenv NS_FONT_DEBUGFFF

for sh/bash/ksh

 export NS_FONT_DEBUG=FFF

(Try running the env command to see if it is set)

Did you restart moz after setting it?

Comment 12

16 years ago
using moz1.1a on winme.  wfm.

reporter, what is your default font setup?

(Reporter)

Comment 13

16 years ago
NS_FONT_DEBUG=FFF output is here -> http://david.ath.cx/ns_font_debug.txt

my default font setup is anti-aliased western adobe-new cent. schoolbk size 18
and by the way, it still crashes if i set a minumum font size. seems to be some
sort of overflow, if i hold "ctrl -".
(Assignee)

Comment 14

16 years ago
I wonder if this is realted to bug 155175.

Do you build moz? If so could you try applying attachment 89876 [details] [diff] [review]?
(Reporter)

Comment 15

16 years ago
i doubt it's related...
no i dont build it mozilla, it is version 1.1a - 20020610

Comment 16

16 years ago
This bug may be related to or dup bug 155970.

Comment 17

16 years ago
evicting from b-g (should be in Browser:Fonts)
Assignee: Matti → bstell
Component: Browser-General → Layout

Comment 18

16 years ago
bug 155175 and bug 155970 have both been fixed.  David, can you try a newer build?

layout==fonts?

Comment 19

16 years ago
from David:
-------------------------------------
Lost my bugzilla user/pass.

but it works now with Mozilla 1.1b build 20020722

-David
-------------------------------------
marking WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.