Profile chooser pops up even if StartWithLastProfile=1 is set in FF67

RESOLVED DUPLICATE of bug 1553929

Status

()

defect
RESOLVED DUPLICATE of bug 1553929
2 months ago
2 months ago

People

(Reporter: booyang1, Unassigned)

Tracking

(Regression, {regression})

67 Branch
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox67 wontfix, firefox67.0.1 wontfix, firefox68 fix-optional, firefox69 fix-optional)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

After 67 update in Windows 10/64, the Profile Chooser always pops up when starting FF, even if StartWithLastProfile=1. This occurs across any computer I use, this did not happen until the 67 update the other day.

Actual results:

Current profiles.ini, any edits I do to [Installxxxxx] and [General] get overwritten when FF starts up:

[Install308046B0AF4A39CB]
Default=Profiles/1zbcbr9k.default
Locked=1

[Profile0]
Name=default
IsRelative=0
Path=C:\Users\Tom\AppData\Roaming\Mozilla\Firefox\Profiles\1zbcbr9k.default
Default=1

[General]
StartWithLastProfile=1
Version=2

Expected results:

Profile chooser should not open on startup if StartWithLastProfile=1

(In reply to booyang1 from comment #0)

IsRelative=0
Path=C:\Users\Tom\AppData\Roaming\Mozilla\Firefox\Profiles\1zbcbr9k.default

While Firefox is closed, try replacing that with

IsRelative=1
Path=Profiles/1zbcbr9k.default

Default=1

I don't think this line is needed anymore. At least it's gone from my profiles.ini.

That being said, you shouldn't manually edit the file. You can either enter about:profiles into the address bar or use the profile manager to make changes.

Component: Untriaged → Startup and Profile System
Product: Firefox → Toolkit
Regressed by: 1474285

For whatever reason, this works - I set the IsRelative bit and path manually in profiles.ini, and changed the default bit using about:profiles. Even with a manual edit of Default =1 in profiles.ini, the Profile Editor did not report this profile as Default. After setting this bit, it works as expected.

You may want to look into this since I've been running with the same profiles.ini across multiple machines for longer than I can remember with no problems (8+ years and lord knows how many versions), but now this is an issue in 67 for some reason.

Thanks for your help!

(In reply to booyang1 from comment #2)

Thanks for your help!

You're welcome. Thank you for the update.

You may want to look into this

:mossop Maybe you'd like to have a look.

Flags: needinfo?(dtownsend)
Duplicate of this bug: 1554420

Hi,

I also solved my problem manually, but I don't know why after many years, only Firefox 67 is broken with some profiles...

I have many computers with pre-configured full path (not relatives path) into profiles.ini and Firefox 67 made that broken.

Maybe an idea for future version 67.0.1 to fix profiles.ini automatically ?

Thank you

Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Flags: needinfo?(dtownsend)
Resolution: --- → DUPLICATE
Duplicate of bug: 1553929
You need to log in before you can comment on or make changes to this bug.