Closed Bug 1554577 Opened 1 year ago Closed 1 year ago

External links open in the default profile though another profile was already opened via command line

Categories

(Toolkit :: Startup and Profile System, defect)

67 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1553815

People

(Reporter: nirklars, Unassigned)

References

(Regression)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

  1. Launch Firefox using the -profile "C:\<path to my profile dir>" command line
  2. Open a URL link from an external program or a shortcut associated with Firefox

Actual results:

Firefox will now open the link in the default profile and if you have a custom profile loaded through the commandline it will be ignored. All shortcuts and saved settings will use the default profile instead of the one you already have opened.

Expected results:

Link opened in the currently loaded profile using the command line -profile "C:\<path to my profile dir>"
This occurs since the 67 update both on regular Firefox and Firefox developer.
Best Regards

Component: Untriaged → Startup and Profile System
Product: Firefox → Toolkit
Regressed by: 1474285
Summary: Running a profile from the command line beaks associated weblinks → External links open in the default profile though another profile was already opened via command line
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1553815
You need to log in before you can comment on or make changes to this bug.