Closed Bug 1554590 Opened 3 months ago Closed 3 months ago

Reminder dialogue starts with items collapsed (TB 68 beta)

Categories

(Calendar :: Dialogs, defect)

Lightning 7.0
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jorgk, Assigned: darktrojan)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

The reminder dialogue starts with the items collapsed, that is:

Description            Today at 8:00

You need to click it to see the buttons, details link, etc. That will be surprising to users.

Keywords: regression
Version: Trunk → Lightning 7.0

Looks like richlist.selectedIndex doesn't like items that aren't richlistitems.

Assignee: nobody → geoff
Status: NEW → ASSIGNED
Attachment #9070918 - Flags: review?(philipp)
Attachment #9070918 - Flags: approval-calendar-beta?(philipp)
Attachment #9070918 - Flags: review?(philipp)
Attachment #9070918 - Flags: review+
Attachment #9070918 - Flags: approval-calendar-beta?(philipp)
Attachment #9070918 - Flags: approval-calendar-beta+
Keywords: checkin-needed

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/f6d100d63838
Select first item in alarm dialog. r=philipp

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 7.1
Target Milestone: 7.1 → 7.0

Working on beta 68, thanks.

Status: RESOLVED → VERIFIED

(In reply to Geoff Lankow (:darktrojan) from comment #2)

Looks like richlist.selectedIndex doesn't like items that aren't richlistitems.

Maybe we should make sure they are? What are they?

calendar-alarm-widget.

You need to log in before you can comment on or make changes to this bug.