Closed Bug 1555020 Opened 1 year ago Closed 1 year ago

Firefox closes itself whenever I click the "X" button on the find bar

Categories

(Toolkit :: Find Toolbar, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox67.0.1 --- unaffected
firefox68 --- unaffected
firefox69 --- verified

People

(Reporter: sefeng, Assigned: ehsan)

References

(Regression)

Details

(Keywords: nightly-community, regression)

Attachments

(1 file)

Summary: Firefox closes itself whenever I close the "X" button on the find bar → Firefox closes itself whenever I click the "X" button on the find bar

I'm also seeing this.

hey Ehsan, can you see the problem here?

Flags: needinfo?(ehsan)

https://hg.mozilla.org/integration/autoland/rev/a9b24ae04ca3684c286b4c8504d694b2426f255c#l24.12

-      <toolbarbutton anonid="find-closebutton" class="findbar-closebutton close-icon" data-l10n-id="findbar-find-button-close" oncommand="close();" />
+      <toolbarbutton anonid="find-closebutton" class="findbar-closebutton close-icon" data-l10n-id="findbar-find-button-close" oncommand="window.close();" />

That'd be it. Before, it called the close method on the Findbar class, and now it calls window.close() :-\

AFAICT this particular change just needs reverting, but it's probably also worth checking the other changes in the patch...

Duplicate of this bug: 1554996
Regressed by: 1549560
Assignee: nobody → ehsan
Flags: needinfo?(ehsan)
Component: DOM: Core & HTML → Find Toolbar
Product: Core → Toolkit

(In reply to :Gijs (he/him) from comment #3)

https://hg.mozilla.org/integration/autoland/rev/a9b24ae04ca3684c286b4c8504d694b2426f255c#l24.12

-      <toolbarbutton anonid="find-closebutton" class="findbar-closebutton close-icon" data-l10n-id="findbar-find-button-close" oncommand="close();" />
+      <toolbarbutton anonid="find-closebutton" class="findbar-closebutton close-icon" data-l10n-id="findbar-find-button-close" oncommand="window.close();" />

That'd be it. Before, it called the close method on the Findbar class, and now it calls window.close() :-\

AFAICT this particular change just needs reverting, but it's probably also worth checking the other changes in the patch...

I tested the rest manually just now and I don't believe any of the other ones are similarly affected.

Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/91a6407ed181
Make sure closing the findbar doesn't close the entire window; r=mossop
Duplicate of this bug: 1555124
Duplicate of this bug: 1555221
Priority: -- → P1
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

I'm confirming that bug is fixed, starting in Mozilla Firefox Nightly 69.0a1 (2019-05-29), so I'm marking this bug as VERIFIED.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.