Closed Bug 1555037 Opened 2 years ago Closed 2 years ago

Support SuperProperty in field initializers

Categories

(Core :: JavaScript Engine, task, P1)

task

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: jorendorff, Assigned: jorendorff)

References

Details

Attachments

(2 files, 1 obsolete file)

There are tests for this, but currently disabled because I thought the tests were buggy. I was wrong.

super.x is supposed to work in field initializers. They count as methods.

Attachment #9071329 - Attachment is obsolete: true
Pushed by jorendorff@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ad81cd789859
Part 1: Refactor code for emitting the .initializers array into ClassEmitter. r=arai
https://hg.mozilla.org/integration/autoland/rev/9a263a237c4c
Part 2: Support SuperProperty in field initializers. r=arai
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Regressions: 1562102
You need to log in before you can comment on or make changes to this bug.