menus get confused (specifically the cascading file menu pops up in the wrong place)

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: axm135, Assigned: hyatt)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
see the picture.  this might be a gtk bug, so let me know if you want me to bug
someone else.
I never saw this on win32..

(Reporter)

Comment 2

17 years ago
That's why I'm thinking its a GTK/Glib bug not a mozilla bug.  I mean, that is
the windowing toolkit used, right?

Comment 3

17 years ago
if you think it's a toolkit/widgets menus bug then please pick that component.

i've seen this before, i probably even filed a bug for it.

please indicate: vendor, package and version where you've experienced this for
each of these:
mozilla
window manager
x11 server
gtk1
glib
libc
kernel
Assignee: Matti → hyatt
Component: Browser-General → XP Toolkit/Widgets: Menus
QA Contact: asa → shrir
Reporter, I hae noticed that the given URL is no longer valid, could you please
try the following:

- Give as much information as possible as requested in comment 3
- Retest with a newer version of mozilla either the latest (stable) milestone or
 a recent nightly
- If the problem persist please update the URL to the screenshot, or even better
attach the screenshot to the bug, 
(Reporter)

Comment 5

15 years ago
I don't see the behavior anymore --- this bug is over a year old, I had
forgotten I even had it open.  I makred it fixed, since I think newer versions
of mozilla/gtk don't have the problem.  FWIW, I don't have the jpeg anymore. 
But what would happen was if mozilla was down near the lower right edge of the
screen, and I clicked on the file menu, it would pop up halfway across the
screen --- really wacky.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 6

15 years ago
FIXED isn't right unless there's a specific checkin that fixed the bug; use
WORKSFORME instead.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 7

15 years ago
.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.