Closed Bug 1555255 Opened 5 months ago Closed 4 months ago

Make `mach android archive-geckoview` uses docs package rather than resolving d.android.com online

Categories

(Firefox Build System :: Android Studio and Gradle Integration, defect, P5)

defect

Tracking

(firefox-esr60 unaffected, firefox67 wontfix, firefox68 fixed, firefox69 fixed)

RESOLVED FIXED
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- wontfix
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: nalexander)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: csabou [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=248891830&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/UwLLADzXRIS9P1JW6GCTJw/runs/0/artifacts/public/logs/live_backing.log


[task 2019-05-29T06:59:27.661Z] 06:59:27 INFO - > Task :geckoview:javadocWithGeckoBinariesDebug
[task 2019-05-29T06:59:27.661Z] 06:59:27 INFO - Picked up JAVA_TOOL_OPTIONS: -Dfile.encoding=utf-8
[task 2019-05-29T06:59:35.261Z] 06:59:35 INFO - javadoc: warning - Error fetching URL: https://d.android.com/reference/
[task 2019-05-29T06:59:35.461Z] 06:59:35 INFO - /builds/worker/workspace/build/src/mobile/android/geckoview/src/main/java/org/mozilla/geckoview/GeckoRuntimeSettings.java:301: warning - Tag @link: reference not found: android.app.job.JobScheduler
[task 2019-05-29T06:59:36.061Z] 06:59:36 INFO - 2 warnings
[task 2019-05-29T06:59:36.061Z] 06:59:36 INFO - > Task :geckoview:javadocWithGeckoBinariesDebug FAILED
[task 2019-05-29T06:59:36.061Z] 06:59:36 INFO - FAILURE: Build failed with an exception.
[task 2019-05-29T06:59:36.061Z] 06:59:36 INFO - * Where:
[task 2019-05-29T06:59:36.061Z] 06:59:36 INFO - Build file '/builds/worker/workspace/build/src/mobile/android/geckoview/build.gradle' line: 213
[task 2019-05-29T06:59:36.061Z] 06:59:36 INFO - * What went wrong:
[task 2019-05-29T06:59:36.061Z] 06:59:36 INFO - Execution failed for task ':geckoview:javadocWithGeckoBinariesDebug'.
[task 2019-05-29T06:59:36.061Z] 06:59:36 INFO - > Treating 2 javadoc warning(s) as error(s)
[task 2019-05-29T06:59:36.061Z] 06:59:36 INFO - * Try:
[task 2019-05-29T06:59:36.061Z] 06:59:36 INFO - Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
[task 2019-05-29T06:59:36.061Z] 06:59:36 INFO - * Get more help at https://help.gradle.org
[task 2019-05-29T06:59:36.061Z] 06:59:36 INFO - Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0.
[task 2019-05-29T06:59:36.061Z] 06:59:36 INFO - Use '--warning-mode all' to show the individual deprecation warnings.
[task 2019-05-29T06:59:36.061Z] 06:59:36 INFO - See https://docs.gradle.org/4.10.2/userguide/command_line_interface.html#sec:command_line_warnings
[task 2019-05-29T06:59:36.062Z] 06:59:36 INFO - BUILD FAILED in 58s
[task 2019-05-29T06:59:36.062Z] 06:59:36 INFO - 110 actionable tasks: 93 executed, 17 up-to-date
[task 2019-05-29T06:59:36.515Z] 06:59:36 ERROR - Return code: 1
[task 2019-05-29T06:59:36.515Z] 06:59:36 ERROR - 1 not in success codes: [0]
[task 2019-05-29T06:59:36.515Z] 06:59:36 WARNING - setting return code to 2
[task 2019-05-29T06:59:36.515Z] 06:59:36 FATAL - Halting on failure while running ['/builds/worker/workspace/build/src/obj-x86_64-pc-linux-gnu/_virtualenvs/init/bin/python', 'mach', '--log-no-times', 'android', 'archive-geckoview']
[task 2019-05-29T06:59:36.515Z] 06:59:36 FATAL - Running post_fatal callback...
[task 2019-05-29T06:59:36.516Z] 06:59:36 FATAL - Exiting 2
[task 2019-05-29T06:59:36.516Z] 06:59:36 INFO - [mozharness: 2019-05-29 06:59:36.516035Z] Finished build step (failed)
[task 2019-05-29T06:59:36.516Z] 06:59:36 INFO - Running post-run listener: _parse_build_tests_ccov
[task 2019-05-29T06:59:36.516Z] 06:59:36 INFO - Running post-run listener: _shutdown_sccache
[task 2019-05-29T06:59:36.516Z] 06:59:36 INFO - Running command: ['/builds/worker/workspace/build/src/sccache/sccache', '--stop-server'] in /builds/worker/workspace/build/src
[task 2019-05-29T06:59:36.516Z] 06:59:36 INFO - Copy/paste: /builds/worker/workspace/build/src/sccache/sccache --stop-server
[task 2019-05-29T06:59:36.519Z] 06:59:36 INFO - Stopping sccache server...
[task 2019-05-29T06:59:36.519Z] 06:59:36 INFO - Compile requests 3820
[task 2019-05-29T06:59:36.519Z] 06:59:36 INFO - Compile requests executed 3524
[task 2019-05-29T06:59:36.519Z] 06:59:36 INFO - Cache hits 441
[task 2019-05-29T06:59:36.519Z] 06:59:36 INFO - Cache hits (C/C++) 99
[task 2019-05-29T06:59:36.519Z] 06:59:36 INFO - Cache hits (Rust) 342
[task 2019-05-29T06:59:36.519Z] 06:59:36 INFO - Cache misses 3083
[task 2019-05-29T06:59:36.519Z] 06:59:36 INFO - Cache misses (C/C++) 3067
[task 2019-05-29T06:59:36.520Z] 06:59:36 INFO - Cache misses (Rust) 16
[task 2019-05-29T06:59:36.520Z] 06:59:36 INFO - Cache timeouts 0
[task 2019-05-29T06:59:36.520Z] 06:59:36 INFO - Cache read errors 0
[task 2019-05-29T06:59:36.520Z] 06:59:36 INFO - Forced recaches 0
[task 2019-05-29T06:59:36.520Z] 06:59:36 INFO - Cache write errors 0
[task 2019-05-29T06:59:36.520Z] 06:59:36 INFO - Compilation failures 0
[task 2019-05-29T06:59:36.520Z] 06:59:36 INFO - Cache errors 0
[task 2019-05-29T06:59:36.520Z] 06:59:36 INFO - Non-cacheable compilations 0
[task 2019-05-29T06:59:36.520Z] 06:59:36 INFO - Non-cacheable calls 125
[task 2019-05-29T06:59:36.520Z] 06:59:36 INFO - Non-compilation calls 171
[task 2019-05-29T06:59:36.520Z] 06:59:36 INFO - Unsupported compiler calls 0
[task 2019-05-29T06:59:36.520Z] 06:59:36 INFO - Successful distributed compilations 0
[task 2019-05-29T06:59:36.520Z] 06:59:36 INFO - Failed distributed compilations 0
[task 2019-05-29T06:59:36.520Z] 06:59:36 INFO - Average cache write 0.086 s
[task 2019-05-29T06:59:36.520Z] 06:59:36 INFO - Average cache read miss 3.302 s
[task 2019-05-29T06:59:36.520Z] 06:59:36 INFO - Average cache read hit 0.094 s
[task 2019-05-29T06:59:36.520Z] 06:59:36 INFO - Non-cacheable reasons:
[task 2019-05-29T06:59:36.520Z] 06:59:36 INFO - crate-type 66
[task 2019-05-29T06:59:36.521Z] 06:59:36 INFO - -fsyntax-only 37
[task 2019-05-29T06:59:36.521Z] 06:59:36 INFO - - 10
[task 2019-05-29T06:59:36.521Z] 06:59:36 INFO - unknown source language 10
[task 2019-05-29T06:59:36.521Z] 06:59:36 INFO - -E 2
[task 2019-05-29T06:59:36.521Z] 06:59:36 INFO - Cache location S3, bucket: Bucket(name=taskcluster-level-3-sccache-us-west-2, base_url=http://taskcluster-level-3-sccache-us-west-2.s3.amazonaws.com/)
[task 2019-05-29T06:59:36.521Z] 06:59:36 INFO - Return code: 0
[task 2019-05-29T06:59:36.521Z] 06:59:36 INFO - Running post-run listener: _summarize
[task 2019-05-29T06:59:36.521Z] 06:59:36 ERROR - # TBPL FAILURE #
[task 2019-05-29T06:59:36.521Z] 06:59:36 INFO - [mozharness: 2019-05-29 06:59:36.521497Z] FxDesktopBuild summary:
[task 2019-05-29T06:59:36.521Z] 06:59:36 ERROR - # TBPL FAILURE #
[taskcluster 2019-05-29 06:59:37.228Z] === Task Finished ===

Summary: Intermittent Halting on failure while running ['/builds/worker/workspace/build/src/obj-x86_64-pc-linux-gnu/_virtualenvs/init/bin/python', 'mach', '--log-no-times', 'android', 'archive-geckoview'] → Intermittent Android 5.0 x86-64 opt Halting on failure while running ['/builds/worker/workspace/build/src/obj-x86_64-pc-linux-gnu/_virtualenvs/init/bin/python', 'mach', '--log-no-times', 'android', 'archive-geckoview']
Summary: Intermittent Android 5.0 x86-64 opt Halting on failure while running ['/builds/worker/workspace/build/src/obj-x86_64-pc-linux-gnu/_virtualenvs/init/bin/python', 'mach', '--log-no-times', 'android', 'archive-geckoview'] → Intermittent Halting on failure while running ['/builds/worker/workspace/build/src/obj-x86_64-pc-linux-gnu/_virtualenvs/init/bin/python', 'mach', '--log-no-times', 'android', 'archive-geckoview']

I think these failures are just due to https://d.android.com/reference/ not returning, resulting in an undefined @link document element.

[task 2019-05-29T06:59:35.261Z] 06:59:35 INFO - javadoc: warning - Error fetching URL: https://d.android.com/reference/
[task 2019-05-29T06:59:35.461Z] 06:59:35 INFO - /builds/worker/workspace/build/src/mobile/android/geckoview/src/main/java/org/mozilla/geckoview/GeckoRuntimeSettings.java:301: warning - Tag @link: reference not found: android.app.job.JobScheduler

Not sure if we can do anything but retry in this case.

:nalexander, can timeouts be tweaked for this task (javadocWithGeckoBinariesDebug in mobile/android/geckoview/build.gradle)?

Flags: needinfo?(nalexander)

See https://stackoverflow.com/a/24026735.

Adding the docs package requirement is not ideal, but it's not worth
the effort to install it only in automation (or in the relevant task),
and it's not that large: 1.0G on my macOS installation.

Pushed by nalexander@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/44a166a4efdb
Don't require a network connection to produce Javadoc. r=geckoview-reviewers,agi
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Assignee: nobody → nalexander

For more details, see:
https://treeherder.mozilla.org/intermittent-failures.html#/bugdetails?bug=1555255&startday=2019-06-24&endday=2019-06-30&tree=all

This graph looks great: failures drop to 0 on the 25th, when the patch landed, suggesting this is an appropriate fix.

Summary: Intermittent Halting on failure while running ['/builds/worker/workspace/build/src/obj-x86_64-pc-linux-gnu/_virtualenvs/init/bin/python', 'mach', '--log-no-times', 'android', 'archive-geckoview'] → Make `mach android archive-geckoview` uses docs package rather than resolving d.android.com online
Component: General → Build Config & IDE Support
Product: Release Engineering → Firefox for Android
QA Contact: catlee
Product: Firefox for Android → Firefox Build System
You need to log in before you can comment on or make changes to this bug.