Closed Bug 1555425 Opened 4 months ago Closed 4 months ago

Enable Web Authentication in all Android channels

Categories

(Core :: DOM: Web Authentication, enhancement, P1)

68 Branch
Unspecified
Android
enhancement

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox67 --- wontfix
firefox67.0.1 --- wontfix
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: jcj, Assigned: jcj)

References

Details

(Whiteboard: [bcs:p2])

Attachments

(1 file)

There are no showstopping bugs for Web Authentication on Android, so while we wait for QA sign-off, let's go ahead and pref it on. If we need, we can pref-back-off in a later Beta.

Ryan, is there any pref for "Just Fennec, not Fenix" beyond FENNEC_NIGHTLY? Otherwise, I think we just want maybe to land directly into mozilla-beta so as to not turn on in Fenix unexpectedly?

Flags: needinfo?(ryanvm)

(In reply to J.C. Jones [:jcj] (he/him) from comment #1)

Ryan, is there any pref for "Just Fennec, not Fenix" beyond FENNEC_NIGHTLY? Otherwise, I think we just want maybe to land directly into mozilla-beta so as to not turn on in Fenix unexpectedly?

I don't think we can selectively enable for just Fennec. Also, I'm not sure if landing this on Beta won't affect Fenix. I think we're using GV Beta builds for Fenix? Though TBH, I'm having a bit of a hard time keeping straight which GeckoView is being used in which products.

Flags: needinfo?(ryanvm) → needinfo?(snorp)

For prefs, you can enable in mobile.js for Fennec and disable in geckoview-prefs.js for GeckoView.

Flags: needinfo?(snorp)
Attachment #9068461 - Attachment description: Bug 1555425 - Enable Web Authentication in all Android channels → Bug 1555425 - Enable Web Authentication in all Fennec Android channels

68=affected because we'll want to uplift this fix to Fennec 68 Beta.

Pushed by jjones@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b871bf099557
Enable Web Authentication in all Fennec Android channels r=cpeterson,KevinJacobs

Comment on attachment 9068461 [details]
Bug 1555425 - Enable Web Authentication in all Fennec Android channels

Beta/Release Uplift Approval Request

  • User impact if declined: No WebAuthn on Android until Fenix can adopt the feature (which is pending whitelist updates)
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce: (Just a pref flip)
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Has received QE signoff. Just a pref-flip to enable.
  • String changes made/needed: None
Attachment #9068461 - Flags: approval-mozilla-beta?
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Comment on attachment 9068461 [details]
Bug 1555425 - Enable Web Authentication in all Fennec Android channels

webauthn for fennec beta/release, approved for 68.0b9

Attachment #9068461 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.