Closed Bug 1555661 Opened 6 months ago Closed 6 months ago

Google is listing two client codes in the search url

Categories

(Firefox :: Search, defect, P1, major)

defect
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 69
Iteration:
69.2 - May 27 - Jun 9
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 blocking verified
firefox69 --- verified

People

(Reporter: standard8, Assigned: standard8)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

This was noticed in bug 1554912, but splitting out as it seems a slightly different issue.

The URLs we're generating for google searches contain two client parameters, e.g. https://www.google.com/search?client=firefox-b-d&q=test&client=firefox-b-ab

firefox-b-ab is an old code, and firefox-b-d is the correct code. This is most likely a regression from bug 1496075.

The issue is that browser/components/search/extensions/google/_locales/b-d/messages.json doesn't have a param_keyword listing. As a result, the extension falls back to using the en value, which has the old param_keyword of firefox-b-ab.

As far as I know we don't use the old codes at all, so I think we should remove those locale options, and simplify the manifest.json for Google.

I'll also add a tests and do a quick check of the other multi-locales.

Tracking for 68, as this is a regression there and we need this fixing for it.

Assignee: nobody → standard8
Status: NEW → ASSIGNED
Points: --- → 2
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c5906d50f330
Fix client code inclusion in Google urls. r=daleharvey

Ok, it looks like it doesn't like having the default locale as "b-d". I'll add en back and make it default to the same as b-d. That doesn't functionally change anything, and when we do the modernisation of the search config, we'll be pulling the codes out of the extensions, so we should be able to drop this multi-locale setup for Google at least.

Flags: needinfo?(standard8)
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/858d04f452e2
Fix client code inclusion in Google urls. r=daleharvey

Ok, latest backout was due to the files now being duplicates. I've added a bit of whitespace and that seems to fix it. As I said before, we can hopefully remove this later, but for now we need this.

Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/70d1aed47149
Fix client code inclusion in Google urls. r=daleharvey
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

QE Verify: Please check that the URLs contain only one "client" parameter for both US region based en-US, and for a locale where the region is also outside of the US (xref bug 1554912 comment 0).

Flags: qe-verify+

Comment on attachment 9068705 [details]
Bug 1555661 - Fix client code inclusion in Google urls. r?daleharvey

Beta/Release Uplift Approval Request

  • User impact if declined: None, however product search codes may be invalid.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See previous comment
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Simple well-defined fixes to just the Google search engine setup, covered by tests.
  • String changes made/needed: None
Attachment #9068705 - Flags: approval-mozilla-beta?

Comment on attachment 9068705 [details]
Bug 1555661 - Fix client code inclusion in Google urls. r?daleharvey

google search codes fix, approved for 68.0b7

Attachment #9068705 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I’ve reproduced the issue with Fx 69.0a1 (2019-05-30) on Windows 10 x64.
I can’t see any duplicate client codes in the search url with different locales and different regions using Nord VPN (eg. en-US, en-GB, fr, de, ru, ja, zh-CN, es-Es, pl, nn-NO, it) with Fx 69.0a1 (2019-06-04) and Fx 68.0b7 on Windows 10 x64, Ubuntu 18.04 x64 and macOS 10.13.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Iteration: --- → 69.2 - May 27 - Jun 9
You need to log in before you can comment on or make changes to this bug.