Closed Bug 1555908 Opened 4 years ago Closed 4 years ago

Remove event.target null checks in tabbrowser.xml

Categories

(Firefox :: Tabbed Browser, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 69
Tracking Status
firefox69 --- fixed

People

(Reporter: dao, Assigned: surkov)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Bug 1519514 added some null checks for event.target in tabbrowser.xml. However, event.target cannot be null.

Alexander, could you please look into cleaning this up?

Flags: needinfo?(surkov.alexander)

Bugbug thinks this bug is a defect, but please change it back in case of error.

Type: task → defect
Assignee: nobody → surkov.alexander
Type: defect → task
Flags: needinfo?(surkov.alexander)

(In reply to Release mgmt bot [:sylvestre / :calixte] from comment #2)

Bugbug thinks this bug is a defect, but please change it back in case of error.

This was basically wrong, but as it turns out now there's potentially a bug here that we should fix as part of this: https://phabricator.services.mozilla.com/D33266#inline-197651

Type: task → defect
Priority: P3 → P1
Pushed by asurkov@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f5e4b365f02e
Remove event.target null checks in tabbrowser.xml, r=dao
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
Has Regression Range: --- → yes
Keywords: regression
You need to log in before you can comment on or make changes to this bug.