the file:// protocol does not work in the sidebar

VERIFIED DUPLICATE of bug 113994

Status

SeaMonkey
Sidebar
VERIFIED DUPLICATE of bug 113994
16 years ago
13 years ago

People

(Reporter: Macarie Neculai, Assigned: Samir Gehani)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0; .NET CLR 
1.0.3705)
BuildID:    2002061104

    I want to add a sidebar item from my local hard drive. It has the form 
file:///D:/htdocs/test_mozilla.html. I tried to add it with the
window.sidebar.addPanel function, but it did not work.
    I wanted to work around this and added a valid http added to the sidebar 
(http://www.mozilla.org) and after that to modify in the panels.rdf file from 
the profile directory. I modified there and it still does not work. The page in 
the sidebar tries to load (the "Loading..." animation is displayed), but it 
fails and the sidebar item remains empty.

    I need this to have acces to some navigator preferences that I have no 
other way to access (I tried to create a test certificate and use that to sign 
a script but I failed).

Reproducible: Always
Steps to Reproduce:
1. Try to add a new item to the sidebar with a file:// protocol.
2.
3.

Expected Results:     I think it should display the page taken from the local 
hard drive.

Comment 1

16 years ago
I reproduced this Bug on Windows NT 4 SP6a German and Mozilla 1.0 German.
I want to set my own sidebar for specific links etc. My own "sidebar.html" was
on a mounted network drive.

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 113994 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.