Closed Bug 1556174 Opened 1 year ago Closed 1 month ago

Some types of Animated Gif posted on twitter.com are not loaded, only show Black

Categories

(Core :: Audio/Video, defect, P3)

66 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1479203

People

(Reporter: therustyman22, Unassigned)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

Browsing Gif posts on Twitter.com. I had the issue my self when once posted gif generated by virtual dub.

Actual results:

Not all twitter Gif posts load and play. They just show black image after load.
The issue start appearing with version 66.0 (64-bit). With 67.0 it is worse. Even with disabled acceleration and even in FF_safe mode.

Expected results:

All twitter gif posts may load correctly.

Component: Untriaged → ImageLib
Product: Firefox → Core
Version: 67 Branch → 66 Branch
Priority: -- → P3
Whiteboard: [gfx-noted]

I would guess that the problem is at a higher level than imagelib based on the video in the attachment. It looks as though the gifs on the tweets go black, including the blue play button on top of them (before the user has clicked on the gif to start it), but the little "GIF" tag in the bottom left corner is still there. The blue play button is actually an svg. If it was an imagelib problem you wouldn't expect those two images to go black at the same time in every case.

I have this problem as well, and with the video upload website BitChute, starting with 66. I've been using FF since it's inception. Except for the recent add-on debacle (lt's kinda funny now), am mostly happy with the browser itself.

Twitter: Some videos play fine, others do not, it appears to be related to what the cell videographer used to film or upload the video with, but that's a guess. No GIF play at all. When scrolling down a thread the top edge of a GIF briefly flashes the true image, sometimes including the blue play button mid-image, usually not, and defaults to a black square with the GIF bug lower left corner.

BitChute: I login, allow all scripts to run, change FF default of autoplay audio Off to On, navigate to a notification of a new video upload, land on the page, hear the video but see nothing at all, not even a placeholder. The Disqus comments also do not display. There are no page elements displayed, either. Just blank space below the BitChute page header. I have filed a support ticket at BitChute but have not heard back now two weeks hence.

I have tried Ctrl+F5, no good. I tried unchecking Acceleration Hardware, no good. I checked about:config for Media settings, all appear to be at Default/Normal. I tried turning off add-ons one at a time, no good. I checked my anti-virus for any settings that might be offensive, none in Norton that I could find.

While I can live without the Twitter GIFs, I need to access the content on BitChute.
I will appreciate any help and am happy to assist in any way I can. First time bug reporter, so please forgive any posting goof up.

Regards,
Iggy
Win7Pro/Dell Desktop/FF67

Same problem.
Looking at https://www.reddit.com/r/firefox/comments/ags737/certain_twitterimgur_videos_wont_play_even_in/ it's the same problem as here https://bugzilla.mozilla.org/show_bug.cgi?id=1479203#c10
tl;dr, an encoding problem only Win7 User have. Just disabling harware acceleration doesn't work this time.
The videos won't play in any other browser either. They also don't play in WMP when you download them, but in other players like VLC.

I see the same thing on Twitter. From https://twitter.com/JennerallyJenn/status/1155664918072315904

In that Tweet thread I looked at the Media tab of Page Info to get the direct URLs to the videos:

Not playing: https://video.twimg.com/tweet_video/EAm_G79U0AEdO5n.mp4

From MPC-HC info: Video: MPEG4 Video (H264) 800x450 25fps 310kbps [V: Twitter v2 (h264 main L5.2, yuv420p, 800x450, 310 kb/s)]

Another on that thread that plays: https://video.twimg.com/tweet_video/EAo0CMnXoAEDPZV.mp4

From MPC-HC info: Video: MPEG4 Video (H264) 454x352 10fps 161kbps [V: Twitter v2 (h264 main L5.1, yuv420p, 454x352, 161 kb/s)]

Firefox 68.0.1 Windows 7 Pro NVidia 550ti w/ 391.35 drivers, the last made for the card. Seems like Chrome has a problem with that video as well. So, a Windows 7 thing?

Today i find out my Firefox is unable to play Advanced Video Codec Main@L 5.2 Video files.
I was angry so i copy the twitter gif post link and downloaded that "wont load" file and find out it is small .mp4 video file that act like 0 sec video if open by firefox.

With MPC-HCx64 (media player classic x64) it plays normal and i find out properties by media info tab.
Format : AVC
Format profile : Main@L5.2
Codec ID: avc1
Bit rate: 604 kb/s
Title : Twitter v2
Writing library : x264 core 157
Encoding settings: cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x1:0x111 / me=hex / subme=3 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=0 / 8x8dct=0 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=0 / threads=6 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc=crf / mbtree=0 / crf=20.0 / qcomp=0.60 / qpmin=21 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / pb_ratio=1.30 / aq=2:1.00

Codec configuration box : avcC

Today i find out my Firefox is unable to play Advanced Video Codec Main@L 5.2 Video files.
I was angry so i copy the twitter gif post link and downloaded that "wont load" file and find out it is small .mp4 video file that act like 0 sec video if open by firefox.

With MPC-HCx64 (media player classic x64) it plays normal and i find out properties by media info tab.
Format : AVC
Format profile : Main@L5.2
Codec ID: avc1
Bit rate: 604 kb/s
Title : Twitter v2
Writing library : x264 core 157
Encoding settings: cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x1:0x111 / me=hex / subme=3 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=0 / 8x8dct=0 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=0 / threads=6 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc=crf / mbtree=0 / crf=20.0 / qcomp=0.60 / qpmin=21 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / pb_ratio=1.30 / aq=2:1.00

Codec configuration box : avcC

So by looks of it Firefox on Win7Sp1 has issue with built in codec.

Component: ImageLib → Audio/Video

my Firefox is unable to play Advanced Video of <a href="https://www.7win.org/fake-yeezy-vanta-fu6684.html">Fake Yeezy Vanta</a> files.

Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1479203
You need to log in before you can comment on or make changes to this bug.