Closed Bug 1556487 Opened 6 months ago Closed 5 months ago

Replace HttpChannelParentListener with a more generic class

Categories

(Core :: Networking, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla70
Fission Milestone M4
Tracking Status
firefox70 --- fixed

People

(Reporter: nhi, Assigned: michal)

References

(Blocks 1 open bug)

Details

(Whiteboard: [necko-triaged])

Attachments

(1 file)

Replace current HttpChannelParentListener class with a more general ParentChannelListenerAndInterfaceRequestor class.

see https://docs.google.com/document/d/15kvUKcNavFaV02_R-z6RwxL0_cEM1ygeACnkS2-aOQM/edit#bookmark=id.zbl3jlv9dfp7 for more info

Blocks: 1556492
Blocks: document-channel
No longer blocks: 1556492
Priority: -- → P2
Whiteboard: [necko-triaged]
Assignee: nobody → michal.novotny
Priority: P2 → P1
Fission Milestone: --- → M4
Status: NEW → ASSIGNED
Pushed by mnovotny@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c2669e9513cc
Replace HttpChannelParentListener with a more generic class, r=mayhemer
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Duplicate of this bug: 1556492
You need to log in before you can comment on or make changes to this bug.