Closed Bug 1556611 Opened 2 years ago Closed 2 years ago

ok.ru - flash game won't start

Categories

(External Software Affecting Firefox :: Flash (Adobe), defect)

defect
Not set
normal

Tracking

(firefox-esr60 unaffected, firefox-esr68 disabled, firefox68 wontfix, firefox69+ fixed, firefox70+ fixed)

RESOLVED DUPLICATE of bug 1565980
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- disabled
firefox68 --- wontfix
firefox69 + fixed
firefox70 + fixed

People

(Reporter: ksenia, Unassigned)

References

(Regression, )

Details

(Keywords: regression)

Prerequisites:

  1. OK.ru account created and signed in.
  2. Adobe Flash enabled.

Steps to Reproduce:

  1. Navigate to https://ok.ru/game/knightsclash
  2. Observe behavior.

Expected Behavior:
Game plays.

Actual Behavior:
Game doesn’t play.

Browser / Version: Firefox Nightly 69.0a1 (2019.06.02)
Operating System: Windows 10 Pro

This is not reproducible in Firefox release or Chrome on Windows 10.
Also not reproducible in Firefox Nightly on Mac.

The priority flag is not set for this bug.
:marcia, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(mozillamarcia.knous)

Thanks for filing. Which version of Flash are you using? I know there was a recent update and wondering if it is still happening. Thanks.

Flags: needinfo?(mozillamarcia.knous) → needinfo?(kberezina)

I'm not able to reproduce the issue anymore in the latest Nightly with Flash Version 32.0.0.207. Asked the original reporter to check it as well, just in case :)

So the original reporter mentioned that the issue is still reproducible.

I wasn't able to reproduce it on my Windows VM, so tried on an actual laptop and found a regression window, which points to https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=01140845ccccf650829cffd7c4631732204599f4&tochange=e96752781d2d3961d797cec48c5357c4ec293a23

And log from mozregression:

2019-07-19T22:11:15: INFO : Narrowed inbound regression window from [01140845, e9675278] (4 builds) to [34a413cf, e9675278] (2 builds) (~1 steps left)
2019-07-19T22:11:15: DEBUG : Starting merge handling...
2019-07-19T22:11:15: DEBUG : Using url: https://hg.mozilla.org/integration/mozilla-inbound/json-pushes?changeset=e96752781d2d3961d797cec48c5357c4ec293a23&full=1
2019-07-19T22:11:15: DEBUG : Found commit message:
Bug 1549674: Use the CompositorWindow to draw to when using DoubleBuffering. r=sotaro
Differential Revision: https://phabricator.services.mozilla.com/D30569
2019-07-19T22:11:15: DEBUG : Did not find a branch, checking all integration branches
2019-07-19T22:11:16: INFO : The bisection is done.
2019-07-19T22:11:16: INFO : Stopped

So I guess it's regressed by https://bugzilla.mozilla.org/show_bug.cgi?id=1549674

Bas, would you be able to look into this?

Flags: needinfo?(kberezina) → needinfo?(bas)

[Tracking Requested - why for this release]: New regression on a top site (at least for two games).

Keywords: regression
Regressed by: 1549674

Another affected game: https://ok.ru/game/homeland

Looks like this is related to https://bugzilla.mozilla.org/show_bug.cgi?id=1565980, and it's fixed on Firefox Beta 69.0b9 on Windows 10. I'll test if it's still reproducible for these two games.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1551672
Duplicate of bug: 1565980

The issue is no longer reproducible for me for the both games

Flags: needinfo?(bas)
You need to log in before you can comment on or make changes to this bug.