Closed Bug 1556658 Opened 6 months ago Closed 4 months ago

The Website link from the Lockwise manage page can't be opened using middle click

Categories

(Firefox :: about:logins, enhancement, P2)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 70
Tracking Status
firefox67 --- unaffected
firefox68 --- wontfix
firefox69 --- disabled
firefox70 --- verified

People

(Reporter: cosmin.muntean, Assigned: jaws)

References

Details

(Whiteboard: [passwords:management] [skyline])

Attachments

(2 files)

Attached image link middle click.gif

[Affected Versions]:

  • Lockwise 2.2.3-alpha
  • Nightly 68.0a1

[Affected Platforms]

  • All Windows
  • All Mac
  • All Linux

[Perquisites]

  • Have the Firefox 68 beta or latest Nightly 69 version installed.
  • Have the Lockwise 2.2.3 - alpha extension installed from Lockwise website.
  • Have multiple saved logins.

[Steps to reproduce]:

  1. Open the Firefox browser with the profile from prerequisites.
  2. Click the "Lockwise" toolbar button and click the "Open Lockwise" button from the doorhanger.
  3. Click one of the saved logins from the manage page.
  4. Middle click on the website link.
  5. Observe the behavior.

[Expected results]:

  • The website is opened in a new tab.

[Actual results]:

  • Nothing happens.

[Regression]:

  • This issue is not reproducible on Firefox versions lower than 68. Considering this using mozregression tools I have managed to find the pushlog with the changes that caused this regression.
  • Here is the pushlog: https://tinyurl.com/y6kndlly
  • It seems that bug 1379466 introduced this issue on Firefox 68.

[Notes]:

  • The issue is not reproducible on Firefox 67 release.
  • The issue is also reproducible if you try to open the website by pressing the "Ctrl" key + "Left Click". The website is not opened.
  • The issue is also logged in Lockwsie Github repository in #255.
  • Attached a screen recording with the issue.
Priority: -- → P3
Flags: needinfo?(moz-ian)

Thanks, Cosmin. Unless this is deemed an issue (inconsistent or unexpected behavior with blocked popups) and resolved upstream in Forefox, then we don’t expect to make changes to fix this on the Lockwise addon.

Therefore, I’ll close this as “wontfix” for now unless someone wants to re-purpose the bug for the broader potential “regression”.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → WONTFIX

This regression is also reproducible on "about:logins" page on the latest Nightly 70.0a1 build. In order to reproduce the issue please follow the next STR:

[Prerequsites]:

  • Have at least one password saved in the browser.

[Steps to Reproduce]

  1. Open the latest Nightly 70.0a1 build and navigate to "about:logins" page.
  2. Click one of the saved logins.
  3. Middle click on the website link of the selected login.
  4. Observe the behavior.

[Expected results]:

  • The website is opened in a new tab.

[Actual results]:

  • Nothing happens.

Considering that this regression affects "about:logins" page, I will reopen the issue.

Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Component: DOM: Events → Password Manager
Priority: P3 → --
Product: Core → Toolkit
Whiteboard: [passwords:management] [skyline]

Morphing this to track desktop about:logins.

No longer blocks: 1379466
Status: REOPENED → NEW
Type: defect → enhancement
Flags: needinfo?(moz-ian)
Keywords: regression
Priority: -- → P2
No longer regressed by: 1379466
Hardware: x86_64 → All
Summary: The Website link from the Lockwise manage page can no longer be opened using middle click → The Website link from the Lockwise manage page can't be opened using middle click
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Depends on: 1577177
No longer depends on: 1577177
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/24f529de132f
Middle-clicking on the origin should open the link. r=MattN
Status: ASSIGNED → RESOLVED
Closed: 6 months ago4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

I have verified this issue on the latest Nightly 70.0a1 (2019-08-29) (64-bit) on Windows 7 c64, MacOS 10.14 and Arch Linux 4.12.

  • The Website link can be successfully opened using middle click.
Status: RESOLVED → VERIFIED
Component: Password Manager → about:logins
Product: Toolkit → Firefox
Target Milestone: mozilla70 → Firefox 70
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.