Closed Bug 1556667 Opened 1 year ago Closed 1 year ago

Permafail Tier 2 Android testSessionFilePreservation | failed to verify session JSON - org.mozilla.gecko.tests.SessionTest$AssertException: Assertion failed: principal in JSON matches session principal | got eyIzIjp7fX0=, expected SmIS26zLEdO3ZQBgsLbOywAA

Categories

(Firefox for Android :: Testing, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: RaulG)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [stockwell needswork:owner])

Attachments

(1 file)

Filed by: btara [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=249866757&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/fN1mJJYNT0aGAJ0sInJYdg/runs/0/artifacts/public/logs/live_backing.log


[task 2019-06-04T05:16:56.379Z] 05:16:56 INFO - TEST-START | testSessionFilePreservation
[task 2019-06-04T05:17:17.910Z] 05:17:17 INFO - GECKO | EventExpecter: no longer listening for Gecko:Ready
[task 2019-06-04T05:17:58.772Z] 05:17:58 INFO - GECKO | EventExpecter: no longer listening for Content:DOMContentLoaded
[task 2019-06-04T05:17:58.772Z] 05:17:58 INFO - GECKO | EventExpecter: no longer listening for Content:DOMTitleChanged
[task 2019-06-04T05:18:39.881Z] 05:18:39 INFO - <snipped 779 output lines - if you need more context, please use SimpleTest.requestCompleteLog() in your test>
[task 2019-06-04T05:18:39.881Z] 05:18:39 INFO - Buffered messages logged at 05:18:28
[task 2019-06-04T05:18:39.881Z] 05:18:39 INFO - TEST-PASS | testSessionFilePreservation | principal in JSON matches session principal - SmIS26zLEdO3ZQBgsLbOywAAAAAAAAAAwAAAAAAAAEY= should equal SmIS26zLEdO3ZQBgsLbOywAAAAAAAAAAwAAAAAAAAEY=
[task 2019-06-04T05:18:39.882Z] 05:18:39 INFO - TEST-PASS | testSessionFilePreservation | selected page index matches - 2 should equal 2
...
[task 2019-06-04T05:18:39.905Z] 05:18:39 INFO - TEST-PASS | testSessionFilePreservation | title in JSON matches session title - page4 should equal page4
[task 2019-06-04T05:18:39.905Z] 05:18:39 INFO - TEST-PASS | testSessionFilePreservation | principal in JSON matches session principal - SmIS26zLEdO3ZQBgsLbOywAAAAAAAAAAwAAAAAAAAEY= should equal SmIS26zLEdO3ZQBgsLbOywAAAAAAAAAAwAAAAAAAAEY=
[task 2019-06-04T05:18:39.906Z] 05:18:39 INFO - TEST-PASS | testSessionFilePreservation | selected page index matches - 3 should equal 3
[task 2019-06-04T05:18:39.906Z] 05:18:39 INFO - TEST-PASS | testSessionFilePreservation | URL in JSON matches session URL - about:home should equal about:home
[task 2019-06-04T05:18:39.906Z] 05:18:39 INFO - Buffered messages finished
[task 2019-06-04T05:18:39.906Z] 05:18:39 WARNING - TEST-UNEXPECTED-FAIL | testSessionFilePreservation | failed to verify session JSON - org.mozilla.gecko.tests.SessionTest$AssertException: Assertion failed: principal in JSON matches session principal | got eyIzIjp7fX0=, expected SmIS26zLEdO3ZQBgsLbOywAAAAAAAAAAwAAAAAAAAEY=
[task 2019-06-04T05:18:39.906Z] 05:18:39 INFO - at org.mozilla.gecko.tests.SessionTest$NonFatalAsserter.ok(SessionTest.java:412)
[task 2019-06-04T05:18:39.906Z] 05:18:39 INFO - at org.mozilla.gecko.FennecMochitestAssert.is(FennecMochitestAssert.java:150)
[task 2019-06-04T05:18:39.907Z] 05:18:39 INFO - at org.mozilla.gecko.tests.SessionTest.verifySessionJSON(SessionTest.java:382)
[task 2019-06-04T05:18:39.907Z] 05:18:39 INFO - at org.mozilla.gecko.tests.SessionTest$VerifyJSONCondition.isSatisfied(SessionTest.java:317)
[task 2019-06-04T05:18:39.907Z] 05:18:39 INFO - at com.robotium.solo.Waiter.waitForCondition(Waiter.java:526)
[task 2019-06-04T05:18:39.907Z] 05:18:39 INFO - at com.robotium.solo.Solo.waitForCondition(Solo.java:711)
[task 2019-06-04T05:18:39.907Z] 05:18:39 INFO - at org.mozilla.gecko.tests.testSessionFilePreservation.testSessionFilePreservation(testSessionFilePreservation.java:56)
[task 2019-06-04T05:18:39.907Z] 05:18:39 INFO - at java.lang.reflect.Method.invokeNative(Native Method)
[task 2019-06-04T05:18:39.908Z] 05:18:39 INFO - at java.lang.reflect.Method.invoke(Method.java:525)
[task 2019-06-04T05:18:39.908Z] 05:18:39 INFO - at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:214)
[task 2019-06-04T05:18:39.908Z] 05:18:39 INFO - at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:199)
[task 2019-06-04T05:18:39.908Z] 05:18:39 INFO - at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:192)
[task 2019-06-04T05:18:39.908Z] 05:18:39 INFO - at org.mozilla.gecko.tests.BaseRobocopTest.runTest(BaseRobocopTest.java:188)
[task 2019-06-04T05:18:39.908Z] 05:18:39 INFO - at junit.framework.TestCase.runBare(TestCase.java:134)
[task 2019-06-04T05:18:39.908Z] 05:18:39 INFO - at junit.framework.TestResult$1.protect(TestResult.java:115)
[task 2019-06-04T05:18:39.909Z] 05:18:39 INFO - at junit.framework.TestResult.runProtected(TestResult.java:133)
[task 2019-06-04T05:18:39.909Z] 05:18:39 INFO - at junit.framework.TestResult.run(TestResult.java:118)
[task 2019-06-04T05:18:39.909Z] 05:18:39 INFO - at junit.framework.TestCase.run(TestCase.java:124)
[task 2019-06-04T05:18:39.909Z] 05:18:39 INFO - at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:191)
[task 2019-06-04T05:18:39.909Z] 05:18:39 INFO - at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:176)
[task 2019-06-04T05:18:39.909Z] 05:18:39 INFO - at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:554)
[task 2019-06-04T05:18:39.910Z] 05:18:39 INFO - at org.mozilla.gecko.FennecInstrumentationTestRunner.onStart(FennecInstrumentationTestRunner.java:66)
[task 2019-06-04T05:18:39.910Z] 05:18:39 INFO - at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1701)
[task 2019-06-04T05:18:39.910Z] 05:18:39 INFO - 0 ERROR Exception caught during test! - junit.framework.AssertionFailedError: TEST-UNEXPECTED-FAIL | testSessionFilePreservation | failed to verify session JSON - org.mozilla.gecko.tests.SessionTest$AssertException: Assertion failed: principal in JSON matches session principal | got eyIzIjp7fX0=, expected SmIS26zLEdO3ZQBgsLbOywAAAAAAAAAAwAAAAAAAAEY=
[task 2019-06-04T05:18:39.910Z] 05:18:39 INFO - at org.mozilla.gecko.tests.SessionTest$NonFatalAsserter.ok(SessionTest.java:412)
[task 2019-06-04T05:18:39.910Z] 05:18:39 INFO - at org.mozilla.gecko.FennecMochitestAssert.is(FennecMochitestAssert.java:150)
[task 2019-06-04T05:18:39.911Z] 05:18:39 INFO - at org.mozilla.gecko.tests.SessionTest.verifySessionJSON(SessionTest.java:382)
[task 2019-06-04T05:18:39.911Z] 05:18:39 INFO - at org.mozilla.gecko.tests.SessionTest$VerifyJSONCondition.isSatisfied(SessionTest.java:317)
[task 2019-06-04T05:18:39.911Z] 05:18:39 INFO - at com.robotium.solo.Waiter.waitForCondition(Waiter.java:526)
[task 2019-06-04T05:18:39.911Z] 05:18:39 INFO - at com.robotium.solo.Solo.waitForCondition(Solo.java:711)
[task 2019-06-04T05:18:39.911Z] 05:18:39 INFO - at org.mozilla.gecko.tests.testSessionFilePreservation.testSessionFilePreservation(testSessionFilePreservation.java:56)
[task 2019-06-04T05:18:39.911Z] 05:18:39 INFO - at java.lang.reflect.Method.invokeNative(Native Method)
[task 2019-06-04T05:18:39.911Z] 05:18:39 INFO - at java.lang.reflect.Method.invoke(Method.java:525)
[task 2019-06-04T05:18:39.912Z] 05:18:39 INFO - at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:214)
[task 2019-06-04T05:18:39.912Z] 05:18:39 INFO - at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:199)
[task 2019-06-04T05:18:39.912Z] 05:18:39 INFO - at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:192)
[task 2019-06-04T05:18:39.912Z] 05:18:39 INFO - at org.mozilla.gecko.tests.BaseRobocopTest.runTest(BaseRobocopTest.java:188)
[task 2019-06-04T05:18:39.912Z] 05:18:39 INFO - at junit.framework.TestCase.runBare(TestCase.java:134)
[task 2019-06-04T05:18:39.912Z] 05:18:39 INFO - at junit.framework.TestResult$1.protect(TestResult.java:115)
[task 2019-06-04T05:18:39.912Z] 05:18:39 INFO - at junit.framework.TestResult.runProtected(TestResult.java:133)
[task 2019-06-04T05:18:39.913Z] 05:18:39 INFO - at junit.framework.TestResult.run(TestResult.java:118)
[task 2019-06-04T05:18:39.913Z] 05:18:39 INFO - at junit.framework.TestCase.run(TestCase.java:124)
[task 2019-06-04T05:18:39.913Z] 05:18:39 INFO - at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:191)
[task 2019-06-04T05:18:39.913Z] 05:18:39 INFO - at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:176)
[task 2019-06-04T05:18:39.913Z] 05:18:39 INFO - at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:554)
[task 2019-06-04T05:18:39.913Z] 05:18:39 INFO - at org.mozilla.gecko.FennecInstrumentationTestRunner.onStart(FennecInstrumentationTestRunner.java:66)
[task 2019-06-04T05:18:39.914Z] 05:18:39 INFO - at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1701)
[task 2019-06-04T05:18:39.914Z] 05:18:39 INFO - at junit.framework.Assert.fail(Assert.java:50)
[task 2019-06-04T05:18:39.914Z] 05:18:39 INFO - at org.mozilla.gecko.FennecMochitestAssert._logMochitestResult(FennecMochitestAssert.java:124)
[task 2019-06-04T05:18:39.914Z] 05:18:39 INFO - at org.mozilla.gecko.FennecMochitestAssert.ok(FennecMochitestAssert.java:145)
[task 2019-06-04T05:18:39.914Z] 05:18:39 INFO - at org.mozilla.gecko.tests.testSessionFilePreservation.testSessionFilePreservation(testSessionFilePreservation.java:60)
[task 2019-06-04T05:18:39.914Z] 05:18:39 INFO - at java.lang.reflect.Method.invokeNative(Native Method)
[task 2019-06-04T05:18:39.914Z] 05:18:39 INFO - at java.lang.reflect.Method.invoke(Method.java:525)
[task 2019-06-04T05:18:39.915Z] 05:18:39 INFO - at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:214)
[task 2019-06-04T05:18:39.915Z] 05:18:39 INFO - at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:199)
[task 2019-06-04T05:18:39.915Z] 05:18:39 INFO - at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:192)
[task 2019-06-04T05:18:39.915Z] 05:18:39 INFO - at org.mozilla.gecko.tests.BaseRobocopTest.runTest(BaseRobocopTest.java:188)
[task 2019-06-04T05:18:39.915Z] 05:18:39 INFO - at junit.framework.TestCase.runBare(TestCase.java:134)
[task 2019-06-04T05:18:39.915Z] 05:18:39 INFO - at junit.framework.TestResult$1.protect(TestResult.java:115)
[task 2019-06-04T05:18:39.916Z] 05:18:39 INFO - at junit.framework.TestResult.runProtected(TestResult.java:133)
[task 2019-06-04T05:18:39.916Z] 05:18:39 INFO - at junit.framework.TestResult.run(TestResult.java:118)
[task 2019-06-04T05:18:39.916Z] 05:18:39 INFO - at junit.framework.TestCase.run(TestCase.java:124)
[task 2019-06-04T05:18:39.916Z] 05:18:39 INFO - at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:191)
[task 2019-06-04T05:18:39.916Z] 05:18:39 INFO - at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:176)
[task 2019-06-04T05:18:39.916Z] 05:18:39 INFO - at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:554)
[task 2019-06-04T05:18:39.916Z] 05:18:39 INFO - at org.mozilla.gecko.FennecInstrumentationTestRunner.onStart(FennecInstrumentationTestRunner.java:66)
[task 2019-06-04T05:18:39.917Z] 05:18:39 INFO - at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1701)
[task 2019-06-04T05:18:39.917Z] 05:18:39 WARNING - TEST-UNEXPECTED-FAIL | testSessionFilePreservation | Exception caught - junit.framework.AssertionFailedError: TEST-UNEXPECTED-FAIL | testSessionFilePreservation | failed to verify session JSON - org.mozilla.gecko.tests.SessionTest$AssertException: Assertion failed: principal in JSON matches session principal | got eyIzIjp7fX0=, expected SmIS26zLEdO3ZQBgsLbOywAAAAAAAAAAwAAAAAAAAEY=
[task 2019-06-04T05:18:39.917Z] 05:18:39 INFO - at org.mozilla.gecko.tests.SessionTest$NonFatalAsserter.ok(SessionTest.java:412)
[task 2019-06-04T05:18:39.917Z] 05:18:39 INFO - at org.mozilla.gecko.FennecMochitestAssert.is(FennecMochitestAssert.java:150)
[task 2019-06-04T05:18:39.917Z] 05:18:39 INFO - at org.mozilla.gecko.tests.SessionTest.verifySessionJSON(SessionTest.java:382)
[task 2019-06-04T05:18:39.918Z] 05:18:39 INFO - at org.mozilla.gecko.tests.SessionTest$VerifyJSONCondition.isSatisfied(SessionTest.java:317)
[task 2019-06-04T05:18:39.918Z] 05:18:39 INFO - at com.robotium.solo.Waiter.waitForCondition(Waiter.java:526)
[task 2019-06-04T05:18:39.918Z] 05:18:39 INFO - at com.robotium.solo.Solo.waitForCondition(Solo.java:711)
[task 2019-06-04T05:18:39.918Z] 05:18:39 INFO - at org.mozilla.gecko.tests.testSessionFilePreservation.testSessionFilePreservation(testSessionFilePreservation.java:56)
[task 2019-06-04T05:18:39.918Z] 05:18:39 INFO - at java.lang.reflect.Method.invokeNative(Native Method)
[task 2019-06-04T05:18:39.918Z] 05:18:39 INFO - at java.lang.reflect.Method.invoke(Method.java:525)
[task 2019-06-04T05:18:39.919Z] 05:18:39 INFO - at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:214)
[task 2019-06-04T05:18:39.919Z] 05:18:39 INFO - at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:199)
[task 2019-06-04T05:18:39.919Z] 05:18:39 INFO - at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:192)
[task 2019-06-04T05:18:39.919Z] 05:18:39 INFO - at org.mozilla.gecko.tests.BaseRobocopTest.runTest(BaseRobocopTest.java:188)
[task 2019-06-04T05:18:39.919Z] 05:18:39 INFO - at junit.framework.TestCase.runBare(TestCase.java:134)
[task 2019-06-04T05:18:39.919Z] 05:18:39 INFO - at junit.framework.TestResult$1.protect(TestResult.java:115)
[task 2019-06-04T05:18:39.919Z] 05:18:39 INFO - at junit.framework.TestResult.runProtected(TestResult.java:133)
[task 2019-06-04T05:18:39.920Z] 05:18:39 INFO - at junit.framework.TestResult.run(TestResult.java:118)
[task 2019-06-04T05:18:39.920Z] 05:18:39 INFO - at junit.framework.TestCase.run(TestCase.java:124)
[task 2019-06-04T05:18:39.920Z] 05:18:39 INFO - at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:191)
[task 2019-06-04T05:18:39.920Z] 05:18:39 INFO - at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:176)
[task 2019-06-04T05:18:39.920Z] 05:18:39 INFO - at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:554)
[task 2019-06-04T05:18:39.920Z] 05:18:39 INFO - at org.mozilla.gecko.FennecInstrumentationTestRunner.onStart(FennecInstrumentationTestRunner.java:66)
[task 2019-06-04T05:18:39.921Z] 05:18:39 INFO - at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1701)
[task 2019-06-04T05:18:39.921Z] 05:18:39 INFO - TEST-OK | testSessionFilePreservation | took 106196ms
[task 2019-06-04T05:18:39.921Z] 05:18:39 INFO - TEST-START | Shutdown

:jkt this seems to be introduced by your changes, can you, please, take a look?

Flags: needinfo?(jkt)

eyIzIjp7fX0= is actually base64 for {"3":{}} which is the new serialization of system principal which was SmIS26zLEdO3ZQBgsLbOywAAAAAAAAAAwAAAAAAAAEY before my patch was applied. So it looks like it's doing the right thing. I suggest we disable the test in the short term and fix and verify.

Flags: needinfo?(jkt)
Pushed by rgurzau@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c7e3ab220326
disabled testSessionFilePreservation on Android 4.3 r=aryx
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
You need to log in before you can comment on or make changes to this bug.