Closed Bug 1556709 Opened 3 months ago Closed 3 months ago

[css-sizing] wrong intrinsic size with white-space:nowrap and trailing white-space

Categories

(Core :: Layout: Block and Inline, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 + fixed

People

(Reporter: heycam, Assigned: mats)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image screen shot

See the screen shot.

2:48.09 INFO: First bad revision: 750046b87c63930678adff852290f1b1f76b534c
2:48.09 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d6e4e46dde44d7745040216569ed81546fb450d3&tochange=750046b87c63930678adff852290f1b1f76b534c

Flags: needinfo?(mats)

Ugh - I was just going to report this, and found it already filed.

I think the problem is https://dxr.mozilla.org/mozilla-central/rev/c909c105f914f69054b9a7c6b189ee39fa1cad44/layout/generic/nsBlockFrame.cpp#779-781. We probably need to guard this with some additional style checks -- e.g. we shouldn't do it if white-space:nowrap is in effect.

Has Regression Range: --- → yes
Has STR: --- → yes
Keywords: regression

Bah, I thought OptionallyBreak() would deal with that somehow, but I forgot to check...
(amazing that we have zero tests for this :-))

Assignee: nobody → mats
Component: Layout → Layout: Block and Inline
Flags: needinfo?(mats) → in-testsuite?
OS: Unspecified → All
Hardware: Unspecified → All
Summary: broken layout on Bugzilla → [css-sizing] wrong intrinsic size with white-space:nowrap and trailing white-space
Pushed by mpalmgren@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d4a63f3c0ef6
Only call OptionallyBreak() if we may break at white-space.  r=jfkthame
Flags: in-testsuite? → in-testsuite+
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/17199 for changes under testing/web-platform/tests
Upstream web-platform-tests status checks passed, PR will merge once commit reaches central.
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Upstream PR merged

Verified fixed with Nightly today. Thank you!

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.