Closed Bug 1556997 Opened 2 years ago Closed 2 years ago

Blocking media autoplay doesn't work on "macworld.co.uk"

Categories

(Core :: Audio/Video: Playback, defect)

67 Branch
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: teh6, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

I wanted to read an article on "macworld.co.uk" (the exact article was https://www.macworld.co.uk/news/iphone/iphone-se2-3500611/)

Actual results:

A video started autoplaying. This was odd, as I did not have autoplay allowed for that website. What is weirder is that the autoplay-icon in the URL-bar wasn't there even though the video clearly was playing.

Expected results:

The video should not have autoplayed, and the autoplay-blocking icon in the URL-bar should be there.

Enter about:config into the address bar and set media.autoplay.allow-muted to false.

Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core

Hi, Teh6,
Is the video which started playing automatically muted? If so, it's expected behavior, because we won't block the muted media. If you would like to block muted media as well, please set the pref media.autoplay.allow-muted to false.
Thank you.

Flags: needinfo?(teh6)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0
BuildID: 20190529130856
I can confirm the video playing (w/o audio), and that setting media.autoplay.allow-muted stops the video from playing. This is all intended behavior, as Alastor mentioned above.

However, I cannot reproduce the missing autoplay-blocking icon in the URL-bar.

teh6, can you create a new profile under about:profiles, click "Launch profile in new browser" and then retry your link in the newly launched browser instance? This would help eliminate a profile-specific setting and would be much appreciated!

(In reply to Michael Froman [:mjf] from comment #3)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0
BuildID: 20190529130856
I can confirm the video playing (w/o audio), and that setting media.autoplay.allow-muted stops the video from playing. This is all intended behavior, as Alastor mentioned above.

However, I cannot reproduce the missing autoplay-blocking icon in the URL-bar.

teh6, can you create a new profile under about:profiles, click "Launch profile in new browser" and then retry your link in the newly launched browser instance? This would help eliminate a profile-specific setting and would be much appreciated!

Hmm. When using a new profile, the icon is there. I don't know why it doesn't appear under my profile...
When I changed the media.autoplay.allow-muted to false, the video doesn't autoplay (thanks for showing me that setting btw) and the icon re-appeared. So the problem is fixed.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(teh6)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.