Crash in [@ style::gecko_bindings::structs::root::nsStyleImage::into_image]

VERIFIED FIXED in Firefox 69

Status

()

defect
--
critical
VERIFIED FIXED
3 months ago
Last month

People

(Reporter: calixte, Assigned: emilio)

Tracking

(Blocks 1 bug, Regression, {crash, regression})

Trunk
mozilla69
Unspecified
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox67 unaffected, firefox67.0.1 unaffected, firefox68 unaffected, firefox69blocking verified)

Details

(Whiteboard: [qa-69b-p2], crash signature)

This bug is for crash report bp-f90566f3-6db4-4036-9d0e-63eb30190606.

Top 10 frames of crashing thread:

0 xul.dll GeckoCrash toolkit/xre/nsAppRunner.cpp:5174
1 xul.dll static void gkrust_shared::panic_hook toolkit/library/rust/shared/lib.rs:244
2 xul.dll static void core::ops::function::Fn::call<fn src/libcore/ops/function.rs:69
3 xul.dll static void std::panicking::rust_panic_with_hook src/libstd/panicking.rs:478
4 xul.dll static void std::panicking::continue_panic_fmt src/libstd/panicking.rs:381
5 xul.dll void std::panicking::begin_panic_fmt src/libstd/panicking.rs:336
6 xul.dll static union core::option::Option<style::values::generics::image::Image<style::values::generics::image::Gradient<style::values::computed::image::LineDirection, style::values::computed::length::CSSPixelLength, style::values::computed::length::LengthPercentage, style::values::generics::position::GenericPosition<style::values::computed::length::LengthPercentage, style::values::computed::length::LengthPercentage>, style::values::generics::color::GenericColor<cssparser::color::RGBA>>, style::values::generics::image::MozImageRect<style::values::computed::NumberOrPercentage, style::gecko::url::ComputedImageUrl>, style::gecko::url::ComputedImageUrl>> style::gecko_bindings::structs::root::nsStyleImage::into_image servo/components/style/gecko/conversions.rs:355
7 xul.dll static struct style::properties::longhands::background_image::computed_value::OwnedList<style::values::Either<style::values::None_, style::values::generics::image::Image<style::values::generics::image::Gradient<style::values::computed::image::LineDirection, style::values::computed::length::CSSPixelLength, style::values::computed::length::LengthPercentage, style::values::generics::position::GenericPosition<style::values::computed::length::LengthPercentage, style::values::computed::length::LengthPercentage>, style::values::generics::color::GenericColor<cssparser::color::RGBA>>, style::values::generics::image::MozImageRect<style::values::computed::NumberOrPercentage, style::gecko::url::ComputedImageUrl>, style::gecko::url::ComputedImageUrl>>> style::gecko_bindings::structs::root::mozilla::GeckoBackground::clone_background_image x86_64-pc-windows-msvc/release/build/style-d70eb76fc7337cbc/out/gecko_properties.rs:12097
8 xul.dll static core::result::Result style::gecko_properties::ComputedValues::get_longhand_property_value<nsstring::nsAString> x86_64-pc-windows-msvc/release/build/style-d70eb76fc7337cbc/out/properties.rs:70879
9 xul.dll void geckoservo::glue::Servo_GetPropertyValue servo/ports/geckolib/glue.rs:5935

There are 100 crashes (from 32 installations) in nightly 69 with buildid 20190606112416. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1557110.

[1] https://hg.mozilla.org/mozilla-central/rev?node=25354cfea038

Flags: needinfo?(emilio)
Crash Signature: [@ style::gecko_bindings::structs::root::nsStyleImage::into_image] → [@ style::gecko_bindings::structs::root::nsStyleImage::into_image] [@ style::gecko::conversions::<T>::into_image ]
Assignee: nobody → emilio
Flags: needinfo?(emilio)
Regressed by: 1557212
No longer regressed by: 1557110
Depends on: 1557212
Regressed by: 1557110
No longer regressed by: 1557212
Duplicate of this bug: 1557455
Duplicate of this bug: 1557493

I'll land a fix anyway so it stops crashing.

Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9e77c7f8edc6
Handle default angle in radians. r=me
Duplicate of this bug: 1557633
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Whiteboard: [qa-69b-p2]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.