Closed Bug 1557789 Opened 6 months ago Closed 5 months ago

Expose subcategories in the profile JSON

Categories

(Core :: Gecko Profiler, task, P1)

task

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: mstange, Assigned: mstange, NeedInfo)

References

Details

Attachments

(1 file)

This is a follow-up bug to bug 1500692: We currently have subcategory instrumentation in the tree but the information is not exposed in the profile, because doing so requires a change to the profile format, and the Firefox profiler needs to be updated first to be compatible with the new format.

This bug is about making that format change and exposing the information. The patch has been reviewed by njn before in bug 1500692.

The Firefox profiler patch is landing in PR #2051.

Type: defect → task

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:mstange, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(mstange)
Pushed by mstange@themasta.com:
https://hg.mozilla.org/integration/autoland/rev/1f407c83db16
Expose subcategory information in the profile JSON. r=njn
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Regressions: 1578354
You need to log in before you can comment on or make changes to this bug.