Closed Bug 1558472 Opened 3 years ago Closed 3 years ago

On linux, when title bar is hidden the close button isnt all the way in the top right corner

Categories

(Core :: Widget: Gtk, defect, P3)

67 Branch
Unspecified
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1560702

People

(Reporter: zazcallabah, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

Tested on both linux mint 19.1 with cinnamon, and on kubuntu 19.04.
Firefox version 67.0.1

1: Restart with extensions disabled.
2: Open the Toolbar customization page, uncheck "title bar"
3: Maximize firefox

Actual results:

The close button isn't placed all the way in the top right corner. It stops a few pixels short of the edges, both top and side.

Expected results:

The close button should be all the way in the corner, like it is on windows, and on linux with the title bar enabled. To quote Raymond Chen: "The corners of the screen are very valuable, because users can target them with very little effort. You just slam the mouse in the direction you want, and the cursor goes into the corner." in case someone has forgotten why it should be in the corner.

OS: Unspecified → Linux

Hi
I was trying to replicate this on my ubuntu 18.04.2 LTS 64bit machine and first i was not able to reproduce it but
Then i switched to 1920 x 1080 resolution using the nvidia x server settings application. and i noticed that the close button was cut in half when i followed your steps in the top right corner. But this was not only on Firefox, Chromium had the exact same problem with the close button cut in half when maximized.

Then i touched the menu button in the monitor since most of them synch automatically for best resolution and the setting in the monitor was called "reset" which forces it to auto correct, it took some seconds to allign the image and the close button issue was gone. After i did that i was not able to replicate the problem even with a reboot, the button now shows up correctly.

Please verify if you can correct issue using the monitor configuration buttons.

Also please download Firefox Nightly from here: https://nightly.mozilla.org/ and retest the problem.

Just in case if you still have the issue please create a new profile, you have the steps here:https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles?redirectlocale=en-US&redirectslug=Managing-profiles#w_starting-the-profile-manager

Lastly test if the issue is reproducible in safe mode, here is a link that can help you:
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Regards
Pablo

I can confirm this issue. When title bar is off, I can't close firefox by moving my pointer to the right hand corner. I've tried with every theme but no luck. No other apps have this issue for me on XFCE. I'm using 1600x900 resolution and resetting/autocorrecting the monitor, making a new profile and safe mode do not help. Here is a short screen recording showing the issue: https://gfycat.com/CreamyMelodicGrunion

(In reply to Pablo from comment #1)

Hi
I was trying to replicate this on my ubuntu 18.04.2 LTS 64bit machine and first i was not able to reproduce it but

Have you tried on mint or kubuntu?

Then i switched to 1920 x 1080 resolution using the nvidia x server settings application. and i noticed that the close button was cut in half when i followed your steps in the top right corner. But this was not only on Firefox, Chromium had the exact same problem with the close button cut in half when maximized.

This is not the same issue. Look I captured a video https://youtu.be/B01qD22TFEc
Also, chromium does not have this issue.

Also please download Firefox Nightly from here: https://nightly.mozilla.org/ and retest the problem.

I did in the video linked above.

Just in case if you still have the issue please create a new profile, you have the steps here:https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles?redirectlocale=en-US&redirectslug=Managing-profiles#w_starting-the-profile-manager

I did in the video linked above

Lastly test if the issue is reproducible in safe mode, here is a link that can help you:
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

In my original post I said that step 1 is "Restart with extensions disabled.". That's safemode according to the link you provided.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core
Priority: -- → P3

bug 1560702 has already one duplicate.

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1560702
You need to log in before you can comment on or make changes to this bug.