Closed Bug 1558561 Opened 1 year ago Closed 1 year ago

Launcher Process needs to set length in RTL_OSVERSIONINFOW before calling RtlGetVersion

Categories

(Firefox :: General, defect, P1)

Unspecified
Windows
defect

Tracking

()

RESOLVED FIXED
Firefox 69
Tracking Status
firefox67 --- wontfix
firefox67.0.1 --- wontfix
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: aklotz, Assigned: aklotz)

References

Details

Attachments

(1 file)

Oops.

Pushed by aklotz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4404389d3857
Fix missing population of RTL_OSVERSIONINFOW::dwOSVersionInfoSize; r=mhowell

Bugbug thinks this bug is a task, but please change it back in case of error.

Type: defect → task
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

I think bugbug is probably wrong.

Aaron, I guess you'll want this on 68 since it's marked as blocking 1481546?

Type: task → defect
Flags: needinfo?(aklotz)

Comment on attachment 9071343 [details]
Bug 1558561: Fix missing population of RTL_OSVERSIONINFOW::dwOSVersionInfoSize; r=mhowell!

Beta/Release Uplift Approval Request

  • User impact if declined: Potential false negatives in the DLL blocklist
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): One significant line changed - just initializes a variable.
  • String changes made/needed:
Flags: needinfo?(aklotz)
Attachment #9071343 - Flags: approval-mozilla-beta?

Comment on attachment 9071343 [details]
Bug 1558561: Fix missing population of RTL_OSVERSIONINFOW::dwOSVersionInfoSize; r=mhowell!

launcher process fix, approved for 68.0b10

Attachment #9071343 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.